Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by lariH 1 month, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 13, 2021 at 7:32 am #9776911

lariH

I am trying to: Translate the checkout field labels.

Link to a page where the issue can be seen: hidden link

I expected to see: The checkout labels translated to English

Instead, I got: Hebrew labels

screencapture-carroself-checkout-2-2021-10-13-10_30_49.png
October 13, 2021 at 3:42 pm #9782401

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there.

The proper way to translate strings depends a lot on how they have been implemented inside the theme/plugin and sometimes there are duplicates of the same string that need to be translated.

1. You can go to WPML > String Translation and search for any of the strings and see if there are any results

Here is some very helpful documentation on how to use the String Translation plugin:
https://wpml.org/documentation/getting-started-guide/string-translation/

If it's not there, it could help if you scan the plugin/theme that's generating the strings and then go back to WPML > String Translation and see if the strings show up:
https://wpml.org/documentation/getting-started-guide/theme-localization/

2. If you can't find them inside the WPML > String Translation, they might be added as admin text.

This should be the normal process to find and translate admin text strings:
https://wpml.org/documentation/getting-started-guide/string-translation/finding-strings-that-dont-appear-on-the-string-translation-page/

3. You can also try to go to WPML > String Translation and at the bottom of the page you will find a checkbox called "Look for strings while pages are rendered". You can enable (check) that and then go in the front end to a page where you have that string showing up and then go back to WPML > String Translation and search for that string and see if it now shows up.

4. This link might help, too, in case the string is hard-coded in the theme files:
https://wpml.org/documentation/support/translating-the-theme-you-created/

Please let me know how that goes.

Kind regards,
Mihai Apetrei

October 14, 2021 at 4:02 am #9785573

lariH

Dear Mihai Apetrei,

I have tried the above methods before I have opened the ticket and still haven't found those strings for some reason.

What do you suggest I'll do?

Waiting to hear from you 🙂

October 14, 2021 at 1:51 pm #9790677
lariH

Listen, I am encountering too many problems with your plugin...

I have managed somehow to overcome this current problem but now when I try to edit a custom code snippet on the checkout page (see attached) through the String Translation.
It saves the changes in the editor but does not show the translations at the Front-End.

Also, I have tried to enter the website through a new window (Guest window) and tried to add a product to the cart and it doesn't add any product with a variation at all - I have only three products on the website...

I have somehow bypassed it but only through the admin user when I am logged in and I can't see the variations on the packing slip of the credit company - when I am at the checkout page of the, at the payment.

Before all that, we have translated the whole website and nothing was showing so we started to edit through Elementor in the English language and inserting the translations through the editor and this was not the reason we have purchased the plugin...

Look, there are too many problems and it is kind of disappointing...

I really need help on the matter,
waiting to hear from you 🙂

Screenshot 2021-10-14 164908.png
Screenshot 2021-10-14 164821.png
Screenshot 2021-10-14 164715.png
Screenshot 2021-10-14 164630.png
October 14, 2021 at 2:33 pm #9791171

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hi there and welcome back!

I am happy to hear that you managed to fix the initial issue that was reported in this ticket.

We are allowed to handle only one issue per ticket so I'm moving the new issue that you reported in this new ticket below:
https://wpml.org/forums/topic/split-changes-are-saved-in-wpml-string-translation-but-not-showing-updated-on-the-front-end/

Don't worry, we will take care of each issue one by one until things are good to go.

Please mark this current ticket as resolved.

Mihai

October 19, 2021 at 10:48 am #9817199

lariH

My issue is resolved now. Thank you!