This thread is resolved. Here is a description of the problem and solution.

Problem:Can't translate media files – "Save" button is disabled

Solution:Deactivating the plugin "Schema & Structured Data for WP & AMP", seems to resolve this issue.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by filipC-5 2 months, 1 week ago.

Assigned support staff: Bobby.

Author Posts
April 16, 2020 at 11:53 am #5922179

filipC-5

I can't translate my media files, the "Save" button is disabled. Why? Screenshot attached.

April 18, 2020 at 1:24 am #5936329

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

As a test please try the following

1. Click on the button to save even though it seems disabled
- Does it work?

2. Edit the translation fields
- What are your results?

April 21, 2020 at 11:06 am #5958225

filipC-5

Hey Bobby,

I tried clicking, switching, editing, uploading new photo - nothing seems to work.

April 21, 2020 at 6:51 pm #5962611

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I would like to request temporary access (wp-admin and FTP) to your site to test the issue.
(preferably to a test site where the problem has been replicated if possible)

**Before we proceed I recommend taking FULL BACKUP of your database and your website.**
I often use the Duplicator plugin for this purpose: http://wordpress.org/plugins/duplicator/

You will find the needed fields for this below the comment area when you log in to leave your next reply.
The information you enter is private which means only you and I have access to it.

NOTE: If access to the live site is not possible and the staging site does not exist please provide me with a duplicator package created with the duplicator plugin.

Thank you,
Bobby

April 22, 2020 at 8:34 pm #5972039

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details!

Deactivating the plugin "Schema & Structured Data for WP & AMP", seems to resolve this issue.

Please test and let me know your results, please.

April 27, 2020 at 10:53 am #6001597

filipC-5

My issue is resolved now. Thank you!