Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 8, 2019 at 3:55 pm #3067778

judithV-7

My last support ticket was closed but my issue wasn´t closed yet. We had some delay in answering because of Christmas. Your last answer had number #3030466.

I had contact with our web host and they told me everything is installed correctly. The only problem is that there´s is a 301 redirect from WordPress, location: hidden link y hidden link they don´t understand why the server variable doesn´t reach the plugin.

Hope you can have a look at this.

Thank you.

Regards,

Judith

January 9, 2019 at 6:10 am #3069818

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

Just for a test, could you please go to WPML -> Languages -> Language URL format and set it to Language as a parameter and let me know if those pages can be seen properly?

Regarding the different domains, to be able to use different domains properly, both the domain should point to the exact place and same IPs, not a 301 redirect, at the moment, I pinged your site and the sites are using different IP, which is not a correct confirmation needed.

ping <em><u>hidden link</u></em> ==> 31.7.7.130
ping <em><u>hidden link</u></em> ==> 35.183.141.157

Basically, you should be able to view the same site content from both URLs accordingly, A quick check will be disabled WPML and see if both sites display the same content from there own domain.

https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Look forward to your reply.

Thanks

January 9, 2019 at 10:18 am #3070684

judithV-7

Hi Shekhar, thanks for your quick answer! I´ve set ´language as a parameter´and it looks like I can see the already translated pages properly. The only thing is that I can´t make new translations. When I click the plus icon for the language I want to translate I´m not taken to the Translation Editor, but to the page you can see on the image uploaded.

Regarding to the pings which are going to a diferent place: our .com website is hidden link and not hidden link

January 9, 2019 at 10:50 am #3070843

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Regarding the editor, could you please go to WPML -> Settings page, under the How to translate posts and pages section and classic translation editor to solve the issue.
https://wpml.org/documentation/translating-your-contents/using-the-translation-editor/

Let me know if this helps.

Thanks

January 9, 2019 at 11:22 am #3071104

judithV-7

That worked. When I translate the page (100%, entering ´translation completed´), save it and close it, than it only saves part of my translation. I don´t see the option that the page is translated and when I click again on the plus icon to translate again, it says 17% is translated.

January 9, 2019 at 11:26 am #3071145

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Could you please contact your hosting service provider and ask to increase the max_var_inputs to 10000, this will solve the issue.

Look forward to your reply.

Thanks

January 9, 2019 at 11:36 am #3071246

judithV-7

Ok, will do that.
In the translation manager I see some strange things as well. It says all my last pages which I´ve translated are sent to translation but not completed (images uploaded), should I change something more in my settings as language manager?

January 9, 2019 at 2:29 pm #3072156

judithV-7

Our webhosting company changed it and it looks like it´s translating now correctly! Can you help me with one little small thing:
is it really necessary to click 300 times for every page I want to translate in the translation editor on ´translation complete´ at all the different boxes?? See image 14.59h.
Now I would like to try again to use a different domain for every language. When I click on this option (see image 15.17h) it says the hidden link is valid but the Spanish one not. Why should this be?
After saving and trying to see the translated page in English it doesn´t appear again in the translations (see image 15.25h).
Hope you can help me!

January 9, 2019 at 2:40 pm #3072257

judithV-7

I just found out that WPML isn´t saving at all the option to use different domains for every language.

January 10, 2019 at 4:00 am #3074577

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

is it really necessary to click 300 times for every page I want to translate in the translation editor on ´translation complete´ at all the different boxes??

Yes, you can also try to use the suggestion provided here: https://wpml.org/forums/topic/bulk-complete-translation/#post-2631921

To further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

January 10, 2019 at 10:43 am #3075375

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

To test I added a text.txt file on your ftp and try to access the same file from all the sites, but I can only access the file from hidden link, so it's confirmed that the sites aren't configured correctly as mentioned here, https://wpml.org/2016/04/use-wpml-different-domains-per-language/

Could you please let me know if you are using a parked domain or a subdomain for this server setup? You can also ask your server provided what the recommend as an alternative to server alias on their setup and what settings they recommend to make the file be available to view from all domains?

Look forward to your reply.

Thanks

January 12, 2019 at 9:01 am #3082845

judithV-7

Hi Shekhar, our webhosting company tried to access the file from these 2 URL´s and says that they see the same text file.
hidden link
hidden link
Did you use the ´-´with the chill-outdoor.com site?

January 14, 2019 at 10:11 am #3086651

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello

Shekhar is not available so I will be handling your ticket going forward.

You wrote: "Now I would like to try again to use a different domain for every language. When I click on this option (see image 15.17h) it says the hidden link is valid but the Spanish one not..."

I believe your server setup is still not correct and you should work with your hosting service to understand why the following is not possible:

- when I attempt to log into the various domains as such:
hidden link
hidden link
hidden link

I am unable to. This is essentially WHY you cannot use dashboard administrative functions in all domains. This is not normal since you are logging into the same database and needs to be corrected for WPML language-per-domain to work.

Another oddity is that even if I deactivate your SSL plugins and I confirm that you have set your site and home URLs to use "http", the system is still using "https" when I visit the various domains. This indicates to me that some kind of server setting is at hand even before you reach WordPress and therefore WPML.

So, beyond being able to view the test text file that Shekhar prepared, please work with your server support to ensure that when you use the same administrative userid/password, you are able to also login to the WordPress dashboard from all domains.

Once this is done, your URL format should work completely as expected - meaning that you should be able to save your translations as you wish using this URL format.

January 24, 2019 at 12:06 pm #3124906
judithV-7

Hi Yvette, I´m practising translating pages but I´m having problems with the dimensions of the images. It copies the images but the dimensions are different.

The websites of the pages are: hidden link and the Spanish translation: hidden link

Could you have a look at this?

Thank you,
regards,
Judith

New threads created by Yvette and linked to this one are listed below:

https://wpml.org/forums/topic/split-image-meta-information-does-not-translate-with-elementor/

January 24, 2019 at 3:15 pm #3125846

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Hello!

I am glad to see that you were able to resolve the domain-per-language configuration. As this is a new issue, I am creating a new ticket for it and we will continue working there.

We can close this ticket now.