This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by miguel-angelS-5 4 months, 3 weeks ago.

Assigned support staff: Raja Mohammed.

Author Posts
May 14, 2019 at 4:23 am #3803451

miguel-angelS-5

I am trying to: Translate multiple posts to another languages, actually they are used as regions but 3 in english and 3 in spanish to manage the countries. But i managed to translate ONE post of many, since then everything is a nightmare, i cant translate none of the other posts, the CONTENT windows is missing all times, and this time im using the Standard editor of WordPress, no GUtemberg and no Elementor, i have elementor installed and used for pages, but don´t want to use it on posts except when is really necessary. anyway. The post content field is missing in my translations, also there is a bug in cache, that shows me all the more than 100 jobs i already deleted, i have to do a hard refresh everytime. Please help me this is a nightmare. i would like to add all of the posts to the new languages but simple can´t. Uploaded image still shows all the jobs are already cancelled

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

May 14, 2019 at 10:10 am #3805655

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I think I can understand the issue as missing post content in the translation Which might be due to missing XML configuration in the theme or any other reason which I need to look in your site dashboard.

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

I will be happy to help you better

Kind regards
Raja

May 15, 2019 at 7:11 am #3812981

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi ,

I am taking a duplicator copy of your site to test in my local environment. i will let you know the results soon.

Kind regards
Raja

May 15, 2019 at 2:52 pm #3818027

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I have checked this in detail, This seems like the issue is happening only in the "Global achievements of the team | Q1 2019" page which is not translated yet. I have tried various troubleshooting steps nothing helps, it seems like the database record for the post is either corrupted or missing.

However, When I copy the page content to a fresh page I am able to translate the post content without any issues. Since you have not translated the post yet I would recommend you to copy the content to a new post and delete the existing post also remove it from the trash.

Since the issue is not happening in any other posts this seems to be a feasible solution I can also escalate this to the second tier for a detailed look into the causes of the issue.

Kind regards
Raja

May 15, 2019 at 4:52 pm #3818891

miguel-angelS-5

Ok, i will check this issues you are mentioning and let you know if i need further assistance. Please don´t close this thread yet.

May 16, 2019 at 6:48 am #3822299

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure I will keep this open, Let me know if you still need assistance.

Kind regards
Raja

May 19, 2019 at 5:21 am #3840765

miguel-angelS-5

Thanks apparently is solved, i found that the cause may be the SWEEP plugin that deleted transients and optimized database and revisions. It may have corrupted somehow the post. I have one question. What plugin for database cleaning and optimization does WPML recomends and work well without having this kind of issues?

THanks!

May 20, 2019 at 10:44 am #3846037

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I am not sure how the plugin handles the database optimization, Your issue seems to be more likely a missed string package during translation register. I'm not sure if that is related to database optimization.

However, with a latesh version of WordPress transients are handled by the WordPress core itself. For optimization, we recommend tools like W3 Total cache, Wp Super cache.. etc..

If you encounter the issue again please contact us immediately with a snapshot copy of your site maybe we can look into the details and check the compatibility of sweep plugin with WPML.

Kind regards
Raja

May 20, 2019 at 1:23 pm #3847259

miguel-angelS-5

My issue is resolved now. Thank you!