This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 8.96 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by alexandreA-5 3 weeks, 5 days ago.

Assigned support staff: Riffaz.

Author Posts
August 19, 2019 at 9:09 pm #4419201

alexandreA-5

Hi there
I am trying to translate "Read more" on my RSS FEED

Link to a page where the issue can be seen: hidden link

I expected to see: Check my RSS FEED. It's in english.

Instead, I got: "Read More" is actually in french (Lire la suite).
It should be Read More as before.

August 20, 2019 at 7:12 am #4421003

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

May I ask:
How do you create this feed?
Do you use any plugin for this?
Do you use any custom code for this?

Let me know.

Regards,
Riffaz.

August 20, 2019 at 10:44 am #4422801

alexandreA-5

Hi there,
Rss feed is the one created by WordPress. No custom code. I only use one plugin to add featured image in it that's all (and even with it deactivated, "Read more" is in French).

August 20, 2019 at 11:52 am #4423307

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Some themes may control this.
I could not find your theme anywhere.
Are you using a custom theme?

I checked with the team.
This should work as expected but yours not.
So we need to check this in a fresh installation.

Please follow these steps:
1. go to : hidden link
2. configure the WPML as you have it in your site. at the last step (site key) just click next.
3. install your theme
4. create only one page or post.
5. check the feed. do you have the same issue?
6. let us know how can we check that.

Let me know.

Regards,

August 23, 2019 at 12:09 am #4443225

alexandreA-5

Hey there, theme is Generatepress, this is only a child thème you see.
I don't have time to reset all this new WordPress right now will do it in next days.
In the meantime, if you got any hint for me, please share.
I can post a ticket to Generatepress support too.
Thx

August 25, 2019 at 2:29 pm #4454131

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I don't have time to reset all this new WordPress
- you do not have to create every thing.
- just install the theme
- create only one post as you have.
- Typically this won't take more than 5 minutes.

In the meantime, if you got any hint for me, please share.
- we can not say anything for now until we check the theme.

I can post a ticket to Generatepress support too.
- did you ask them?
- if yes, is there anything useful?

Let me know.

Regards,

August 26, 2019 at 6:35 pm #4460845

alexandreA-5

Tried your way, and set the staging website. Saw that the string was okay there.
I tried to disable all plugins (what i did before posting here), then flushing caches and all, then Read more appeared.
Activated every plugin one by one, found out that plugin GP-PREMIUM (that is the premium part of the theme) was creating this.
Found a snippet to put on functions.php to fix this on Google :
/* FIX READ MORE LABEL GP */
add_filter( 'option_generate_blog_settings', 'tu_translatable_blog_strings' );
function tu_translatable_blog_strings( $options ) {

$options['read_more'] = __( 'Read more', 'generate-blog' );
$options['masonry_load_more'] = __( '+ More','generate-blog' );
$options['masonry_loading'] = __( 'Loading...','generate-blog' );

return $options;

}

Thanks for the help