This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
April 29, 2019 at 1:39 pm #3703901

joostv-20

Hi WPML support!

I am trying to: Translate the slider om my homepage from the default language (English) to Dutch and French.

Link to a page where the issue can be seen:hidden link

I expected to see: A translated slider on the Dutch and French homepage.

Instead, I got: Errors on different lines, which say: Notice: Undefined index: full in /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/media.php on line 212 (, 213, 214 and 215).

I've followed the steps from this page, but still get errors: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

I'm looking forward to your answer.

Yours Sincerely,

Joost

April 30, 2019 at 2:05 am #3707253

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

April 30, 2019 at 7:37 pm #3714617

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joost,

Thank you for the provided details. I took a closer look in your website and noticed it seems you have created your sliders in the english language although the default language of your website is dutch.

Can you please create a test slider in the dutch language then add the english and french version as translations for the default language? Please, follow our instructions carefully at: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/. Please, let me know the results. Have a nice day.

May 3, 2019 at 8:49 am #3732379

joostv-20

Hello Marcos,

Thank you for your prompt reply. I've re-created the slider (no language selected) and added it to the homepage. It worked partly, because the slider is shown, but the error-rules are still shown as well above the slider:

Notice: Undefined index: full in /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/media.php on line 212

- to line 215.

And, additionally, the homepage (in Dutch and French) is mixing up the images at the bottom of the page. It looks like WP is picking images randomly.

May 3, 2019 at 10:15 pm #3738241

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Please, try this basic troubleshooting, so we can confirm we don't have any theme/plugin conflict here:

1 - Make sure your server environment meets our minimum requirements as described at: https://wpml.org/home/minimum-requirements/, you can see your current values at your WordPress Dashboard > WPML > Support > Info menu.

2 - Disable all the plugins except the WPML related ones and the Revolution Slider itself from your WordPress Dashboard > Plugins and see if the issue is gone, if so, activate one plugin at a time untill the culprit one is found.

3 - If the issue persists, temporary change to a default WordPress theme such as the 'TwentySeventeen' theme from your WordPress Dashboard > Appearance > Themes menu.

IMPORTANT: Please, note, a backup is required for security reasons and to avoid any data loss, you can use the https://wordpress.org/plugins/backupwordpress/ plugin for these backup needs.

Please, let me know if the steps above help to fix your issue. Have a nice day.

May 6, 2019 at 1:44 pm #3749153

joostv-20

Hello Marcos,

I can give you the following answers on your suggested points:

1. My server environment meets your minimum requirements. When I go to the info page, everything is green and I get no notifications or errors.

2. When I disable my plugins separately, the following error is being shown on the frond end when I deactivate WooCommerce:

Fatal error: Uncaught Error: Call to undefined function is_product() in /home/husky2/domains/huskyhoreca.nl/public_html/wp-content/themes/Impreza-child/functions.php:141 Stack trace: #0 /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/class-wp-hook.php(286): bbloomer_remove_sidebar_product_pages(Object(WP)) #1 /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(NULL, Array) #2 /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/plugin.php(531): WP_Hook->do_action(Array) #3 /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/class-wp.php(750): do_action_ref_array('wp', Array) #4 /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/functions.php(1105): WP->main('') #5 /home/husky2/domains/huskyhoreca.nl/public_html/wp-blog-header.php(16): wp() #6 /home/husky2/domains/huskyhoreca.nl/public_html/index.php(17): require('/home/husky2/do...') #7 {main} thrown in /home/husky2/domains/huskyhoreca.nl/public_html/wp-content/themes/Impreza-child/functions.php on line 141

When I want to deactivate the WP super cache plugin, I get redirected to a white screen which gives the warning:

Warning: unlink(/home/husky2/domains/huskyhoreca.nl/public_html/wp-content/advanced-cache.php): Permission denied in /home/husky2/domains/huskyhoreca.nl/public_html/wp-content/plugins/wp-super-cache/wp-cache.php on line 161
Could not remove WP_CACHE define from /home/husky2/domains/huskyhoreca.nl/public_html/wp-config.php. Please edit that file and remove the line containing the text 'WP_CACHE'. Then refresh this page.

Also, when I continue to deactivate plugins separately, I sometimes get an error which you can find on the first photo. Also two lines are shown above this error. They say:

Notice: Use of undefined constant ICL_SITEPRESS_VERSION - assumed 'ICL_SITEPRESS_VERSION' in /home/husky2/domains/huskyhoreca.nl/public_html/wp-content/plugins/wp-seo-multilingual/plugin.php on line 15
Warning: Cannot modify header information - headers already sent by (output started at /home/husky2/domains/huskyhoreca.nl/public_html/wp-content/plugins/wp-seo-multilingual/plugin.php:15) in /home/husky2/domains/huskyhoreca.nl/public_html/wp-admin/includes/misc.php on line 1198

3. Changing to a different default wordpress theme, such as twentyseventeen, doesn't solve the problem. It still gives the errors on the Dutch and French page. You can see the errors in the twentyseventeen theme on the second photo.

This is a bit strange, because I first made a new slider for my Dutch page and then duplicated it and changed the text and title of it to English. On the English page I don't get an error.

Do you maybe know if I can change the language of the sliders I create beforehand? It feels like if the plug in stays on English as the default language...

I hope you can help me to fix this problem. It is probably the last issue we come up against before we can launch our website.

I'm looking forward to your answer.

Kind regards,

Joost

May 8, 2019 at 3:12 am #3763537

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. As regarding the following errors:

1- "Fatal error: Uncaught Error: Call to undefined function is_product()"

It happens because you deactivated the WooCommerce theme and your theme doesn't check for WooCommerce activation before calling the 'is_product' function. So not related with WPML usage.

2 - "When I want to deactivate the WP super cache plugin, I get redirected to a white screen which gives the warning"

It happens because your wp-config.php doesn't have writing permissions, so your plugin is unable to write/delete a line on it. Again not related to the revolution slider issue or WPML itself.

See: https://wordpress.org/support/article/changing-file-permissions/

3 - "Notice: Undefined index: full in /home/husky2/domains/huskyhoreca.nl/public_html/wp-includes/media.php on line 212"

Go to your WordPress Dashboard > Plugins deactivate the WPML Media Translation addon and install and run the https://wordpress.org/plugins/regenerate-thumbnails/ plugin. Afther process is finished, please, activate the WPML Media Translation again. Note you should contact your server support/admin in order to fix several permission issues you have in your WordPress installation, I noticed it is not possible to proceed with a plugin installation due permission reasons when creating the plugin folder in your server.

The source of some of your issues is because you have defined your default language as english on a first moment, then you changed that for dutch. I had to re-add your secondary language homepage translations to fix that.

Please, let me know if the steps above help to fix your issue. Have a nice day.

May 10, 2019 at 2:42 pm #3785593

joostv-20

Hi Marcos,

Thanks for your clustered feedback.

I will look further in points 1 and 2. Thanks for showcasing the problems for these two points.

Regarding point 3: After following your steps I still didn't manage to fix the slider. However, I managed to find the error. After I deleted the second slide, which was a HTML5 video, the slider runned smoothly on the English, Dutch and French homepage.

I duplicated the slider and tried to implement the movie by using another way.
In the broken slider it was done by adding a new layer, adding a HTML5 video by a link and use a blank background.

In the duplicated slider I implemented the movie by using the "HTML5 video" option and adding a background picture through the media library. This background picture is being shown for 1 second and after that the movie start. I think if I make a screenshot of the start of the movie, people won't see it has a picture at the beginning. But I haven't tried it yet.

I must admit that I haven't tried to make this slider multilangual by the WPML plugin. So yes, I made three sliders, one for every language. In the future I want to make one slider multilangual of course. Shall I give you an update if it works/if you are interested?

I don't know why it worked, but the case is solved now!

Thanks for your time and help. I must admit that I can say that the support of WPML is very helpful and quick even despite the different time zones.

Kind regards,

Joost

May 10, 2019 at 5:22 pm #3787035

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello Joost,

I am glad it works now and our support efforts attended your expectations. Please, feel free to get in touch anytime you need our assistance in case the multilingual sliders don't work for you. Have a nice day.