This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Noman 1 month, 1 week ago.

Assigned support staff: Noman.

Author Posts
May 29, 2020 at 6:23 pm #6252159

alexandreL-28

Tell us what you are trying to do? Hi!

I created a bilingual web site (French / English) called xtreme4.ca. The Website is dedicated to selling imported vehicles. I translated all the pages as well as the product listings. Unfortunately, there are some words that I just can't find in the string translations... These words all come from the same plugin: automotive listings. (see the picture attached for an example).

How can I translate these words?

Thank you so much !

May 31, 2020 at 5:31 pm #6261245

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow the below steps and let me know how it goes?

1. I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

2. Please scan ‘Automotive Listings’ plugin from WPML >> Theme and plugins localization.

3. Generate .mo files from top of the WPML >> Theme and plugins localization page.

4. Then search the strings from WPML >> String Translation page.

5. Please delete all sorts of caches on your site / server cache / plugin cache / CDN cache (if any), clear browser cache and then check the page.

Thank you

June 1, 2020 at 2:41 pm #6266325

alexandreL-28

Hi,

Thank you Noman for your answer! I tried adding the code to wp-config.php as prescribed (please look at the screenshot attached to this message).

Now, the code appears on my website (see the second picture attached).

I have most definitely done something wrong? Can you help me? Thanks 🙂

Alex

June 1, 2020 at 3:22 pm #6266671

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. Please add that code after starting the PHP tag as you can see in the attached screenshot.

2. Looks like some special characters got copied into wp-config.php file that should not be there. You may first paste below code:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

into notepad++ or similar editor and then paste it to wp-config.php file and I hope then it will work fine.

3. If still an issue persists, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to deactivate and reactivate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 2, 2020 at 1:57 pm #6274975

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have logged in to your site by temporary link that you have provided and went to Listings >> All listings page and tried to view this listing:
hidden link but it showing me below message:
“Sorry, our website is under maintenance.” as you can see in the attached screenshot.

Could you please let me know how I can see this page content.

Thank you

June 2, 2020 at 2:14 pm #6275157

alexandreL-28

Hi Noman,

I'm sorry for your trouble.. I forgot I configured the website to block international connections.

It should be working now!

Thanks

June 3, 2020 at 10:30 am #6282043

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have fixed this issue by following below steps:

1. Entered string in search box from WPML >> String Translation
2. Checked ‘Exact match’ and ‘Include translations’ checkboxes and pressed the ‘Search’ button.
3. Deleted the existing problematic string.
4. Then followed the step #1 and #2 again and entered a dummy translation.

Now strings are showing correctly at fontend of your site, you can update translation by following step #1 and #2. Could you please check and confirm?

Thank you

June 3, 2020 at 2:25 pm #6284771
alexandreL-28

Hi Noman,

It worked for all the problematic strings except two. I tried EVERYTHING for those two and they just won't work... D:

the strings are "12.7 City / 9.7 highway" which should be "11.7 ville / 8.7 autoroute" and "11.7 City / 9.7 highway" which should be "11.7 ville / 8.7 autoroute".

I tried deleting them and rescanning the for those strings but they won't come back. The only way I could make them appear again is by using the "auto register strings for translation" function. Even then, I wouldn't be able to translate them.

How can I translate those specific strings?

thank you so much,

Alex

New threads created by Noman and linked to this one are listed below:

https://wpml.org/forums/topic/cant-translate-two-strings/

June 4, 2020 at 10:49 am #6292989

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

I have created a new ticket since this is a separate issue. Here is the link to the new ticket: https://wpml.org/forums/topic/cant-translate-two-strings/

If your current ticket issue is resolved, you may mark this ticket as resolved and we will continue to work on the new ticket.

Thank you for your cooperation and patience.