Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm trying to translate the Stor URL Slug at WooCommerce Multilingual --> Store URLs

Solution: I kindly ask you to follow these steps: - Make sure that the Store page is created in Spanish. - Edit the Store page -> Save it (this will refresh the entry in the database) -> Create/Update the translations. - Go to Settings -> Permalinks -> Re-save the permalinks configuration.

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Carlos Rojas 5 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
April 3, 2020 at 4:36 pm #5834131

Fabio Fava

Q: Tell us what you are trying to do?

A: I'm trying to translate the Stor URL Slug at WooCommerce Multilingual --> Store URLs

Q: Is there any documentation that you are following?

A: I've done this before, and I'm not sure why it got untranslated. Maybe a recent update?

Q: Is there a similar example that we can see?

A: Not, on the Dev site (dev.flyorganya.com) I get a different issue, wich is weird.

Q: What is the link to your site?

A: hidden link

April 6, 2020 at 6:36 am #5844733

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to follow these steps:
- Make sure that the Store page is created in Spanish.
- Edit the Store page -> Save it (this will refresh the entry in the database) -> Create/Update the translations.
- Go to Settings -> Permalinks -> Re-save the permalinks configuration.

Could you tell me the results of the steps above?

Note: We can continue in Spanish if you desire.

Kind regards,
Carlos

April 6, 2020 at 6:42 am #5844745

Fabio Fava

Carlos Rojas helped me to solve the problem, at the first shot! Thanks!

April 6, 2020 at 12:15 pm #5848187

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos