Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 21 replies, has 2 voices.

Last updated by tchungL 3 years, 5 months ago.

Assigned support staff: Bigul.

Author Posts
February 8, 2018 at 1:56 am #1510781

tchungL

I am trying to: use String translation

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

WeChat Image_20180208114816.jpg
February 9, 2018 at 12:09 pm #1512737

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please explain more about the issue for a better understanding. Which all are the strings are you trying to translate?

To help you faster, I've enabled debug information for this support ticket. Please see this link for how to get this information from your site and give it to us: http://wpml.org/faq/provide-debug-information-faster-support/

--
Thanks!

Bigul

February 15, 2018 at 12:59 am #1518352

tchungL

Can't Translation to chinese in the bi calendar ( tour page)

WeChat Image_20180208114816.jpg
February 15, 2018 at 3:33 pm #1519340

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

Thank you for the debug information. Sorry I am not able to reproduce the issue exactly on your site. So please let me know the exact steps to replicate the issue on your site. Check this image for more details -- hidden link

Please upgrade to the latest version WPML(3.9.3) after a full site backup. Then verify you have followed this procedure or not. If not please try it after a backup and make sure you are getting the expected result or not

1) Visit "WPML>>Theme and plugins localization".
2) Make sure that "Translate by WPML." is active.
3) Scroll down to "Strings in the theme" and click on "Scan the theme for strings".
4) Scroll down to "Strings in the plugins", select the plugin you want to scan and click on "Scan the selected plugins for strings".
5) Once you followed the above steps go under "WPML>>String Translation". All strings available for translation should display in the table you see there and you can translate those strings into the secondary language. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/string-translation/

https://wpml.org/documentation/getting-started-guide/theme-localization/

I have a request. Please upgrade the following configuration for the expected performance of your site.

1) Increase *WP Memory Limit* to *256*(the minimum required memory limit for WPML is *128*). Please check the following links for more details

https://wpml.org/home/minimum-requirements/

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

2) Please increase the *MaxInputVars* of PHP settings to *10000*. Please check the following article for more details or contact your system admin/hosting provider for this purpose.

hidden link

--
Thanks!

Bigul

February 16, 2018 at 9:28 am #1519971

tchungL

Please Check Image

2018.jpg
February 16, 2018 at 4:26 pm #1520466

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

Thank you for the updates. I would like to access admin area of your site for further checking. Please fill the private details fields after a full site backup. Check the following links for more details about our private information sharing.

hidden link

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

--
Thanks!

Bigul

February 19, 2018 at 5:59 pm #1522702

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

Thank you for the login information. Somehow those strings are not registered for translation yet. Maybe it will be happening because of the compatibility issues.

So I have a request. Please allow me to make a duplicator copy of your site using Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

February 19, 2018 at 8:37 pm #1522831

tchungL

Hi Bigul
Yes you can make a duplicator the site

February 20, 2018 at 1:51 pm #1523651

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

Thank you for the permission. I made a duplicator copy of your site and debugging it on my local server now. I will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

February 21, 2018 at 1:14 pm #1524909

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

For your kind updates, the bug is existing for me after the primary debugging procedures. But it works fine when I add German as a secondary language. Please check the attached image.

Therefore I have forwarded the details to our second tier team and waiting for their feedback. We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

2018-02-21_1839.png
February 26, 2018 at 6:44 am #1528748

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

For your kind updates, the bug is existing after the initial debugging procedures. Therefore I am escalating the ticket our compatibility team for further debugging.

We will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

March 2, 2018 at 2:02 pm #1534409

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

For your kind information, this issue is happening because of the *Traveler* theme. The theme is using *FullCalendar* for the Calendar pages. Unfortunately *FullCalendar* library is not supporting Chinese strings.

We have tried in a fresh installation without WPML and Chinese as the site language. But the FullCalendar implementation is incompatible with WordPress when the locale is Chinese simplified.

Therefore please contact your theme support about this. Check the following URL for more details.

hidden link

--
Thanks!

Bigul

March 7, 2018 at 12:24 am #1538417

tchungL

I Still need for of this problem about big calendar translation to mandarin

March 7, 2018 at 12:25 am #1538419

tchungL

Yes need help

March 7, 2018 at 2:43 pm #1539276

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @tchungl,

For your kind information, this issue is happening because of the limitation of Theme. Our compatibility team had following findings. So please contact your theme support on this.

1) Traveler theme is using *FullCalendar* library for the Calendar feature

2) *FullCalendar* library is not supporting Chinese strings

3) We have created a fresh WordPress installation and Chinese Simplified(without WPML) as the site language. In this case also *FullCalendar* library is not loading Chinese strings

4) So this issue is happening without WPML.

--
Thanks!

Bigul