This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Andreas W. 3 months ago.

Assigned support staff: Andreas W..

Author Posts
July 19, 2019 at 5:58 pm

carlosH-17

I am trying to: traslated form that was previously traslated

Link to a page where the issue can be seen: hidden link

I expected to see: the link to traslate

Instead, I got: a strange url type

July 19, 2019 at 6:18 pm #4247835

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

I have created a test page as draft called "WPML Form Test".

I then only pasted the shortocdes for each form names "Default" on the repective pages.

You can see the results here:

hidden link

hidden link

The forms are appearing translated correctly.

Could you please clarify how far the link on your screenshots affects the translation of the form?

Kind regards
Andreas

July 19, 2019 at 9:08 pm #4248257

carlosH-17

Yeah, the problem is in the screenshot, that i wanted to do, is to traslate the contact form itself in this url (as tutorial) hidden link

if i click, it goes to a non url link.

in the traslated administer, selecting the contact form, below default contact, the url points to %26lang%3Den

the form is working, but i want to change the translations

July 19, 2019 at 10:04 pm #4248425

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you, I now realized that the links for "Editar" are not working.

I can see that the WPML Plugins are not updated. Please proceed with the updates.

In case the issue will persist try to run the site in minimal setup:

Disable any additional plugin that is not related to WPML and its add-ons.
If the issue disappears please start reactivating any plugins, or activate them in small groups.

This way verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also, just in case, change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Let me know about the outcome.

Kind regards
Andreas

The topic ‘[Closed] Cant traslate an already traslated form’ is closed to new replies.