This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Divi builder (front-end editor) does not work if you use multiple domains per language

Solution: On WPML > Languages > Language URL Format, you need to check the "Auto sign-in and sign-out users from all domains" option. This way it will also login on the secondary languages, so you will be able to edit the pages on front-end using the Divi builder.

This topic contains 14 replies, has 2 voices.

Last updated by ziga pipan 3 months, 2 weeks ago.

Assigned support staff: Diego Pereira.

Author Posts
May 6, 2019 at 11:50 am #3748017

ziga pipan

something is not working ok, since I'm using different domain for EN language

my site only works ok in primary language
hidden link

when I switch to english, it's like I'm not logged in anymore and I can't edit it.
hidden link

May 6, 2019 at 1:50 pm #3749397

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @ziga pipan, welcome to the WPML support Forum!

Are you able to edit the content of the secondary language through the wp-admin of the main url? (hidden link). If you edit using the main URL, what exactly happens?

All the best,
Diego

May 6, 2019 at 4:02 pm #3750899

ziga pipan

hello

thanks for the quick reply.

When I use the main url I'm logged in ok. But when I click "USE DIVI BUILDER" I get this:
hidden link

the url is showing like the builder is loaded, but it's not and I can't edit anything.

May 7, 2019 at 1:52 pm #3758881

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Please send us access to your WordPress dashboard (website URL, login and password) I'll check and do some tests. - Please use the private field to send the sensitive data - do not post if you do not see it.

It would be better if you give me a test site rather than the live site.

IMPORTANT Please backup a working copy of site files and database before.

Please also install these plugins. They will allow me to take a copy of the website if needed:
Duplicator: https://wordpress.org/plugins/duplicator/
File Manager: https://wordpress.org/plugins/wp-file-manager/
All-in-one WP Migration hidden link

Kind regards,
Diego

May 9, 2019 at 1:53 pm #3776721

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Apparently my access is blocked by location (See screenshot - error 403). Could you check? I am currently in São Paulo / Brazil.

Kind regards,
Diego

May 9, 2019 at 3:55 pm #3777879

ziga pipan

my bad. please try now.

May 10, 2019 at 4:17 pm #3786651

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

Thank you. I checked with my team and there is some similar know issues with Divi and different domains per language that our team is already working on a solution. E.g. this one: https://wpml.org/forums/topic/divi-cross-orgin-problem-using-domain-per-lang-configuration/ - However, it seems that the back-end editor works correctly on your website. Is that correct?

Please note that the recommended way to translate Divi is by using the WPML Translation Editor: https://wpml.org/documentation/theme-compatibility/divi-builder/ - Have you tried translating this way?

There is also a workaround that you can try (I have not tested it yet):
- Temporarily switch to "Language name added as a parameter" URL format
- Edit the page using the front-end editor
- Switch back to "Different domains per language"

IMPORTANT: Please backup your site first before making any change, this is important for security reasons.

Please let me know if it worked for you.

Kind regards,
Diego

May 10, 2019 at 6:43 pm #3787451

ziga pipan

ok, good to know I'm not the only one.
yes, backend works, but I hate to use it.

site is live so switching url's is not an ideal solution, especialy as the site is not mine, I can't tell the client to do that.

in translation managet I can't move and color objects like I want to.

May 13, 2019 at 9:54 pm #3801803

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

I need to run a compatibility test on a clean install before escalating this issue to our second tier team.

I created a test website with a clean WordPress install. You can access it through this link:
hidden link - Through this link you will be automatically logged in.

Please upload Divi and the required plugins to this test install, and create some dummy content to reproduce the issue. After that I will setup multiple domains then check if the same issue occurs on this new install.

Kind regards,
Diego

May 15, 2019 at 8:57 am #3813873

ziga pipan

done
hidden link

May 16, 2019 at 5:45 pm #3828461

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you! I created a local copy using duplicator. I will setup a vhost to emulate different domains per language to run some tests. I will send you a feedback soon.

Kind regards,
Diego

May 17, 2019 at 4:59 pm #3836117

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Doing some tests on the clean install I've found the solution to your issue, which is actually quite simple.

Please check the screenshot. On WPML > Languages > Language URL Format, you need to check the "Auto sign-in and sign-out users from all domains" option. This way it will also login on the secondary languages, so you will be able to edit the pages using the Divi builder.

I checked the option on your back-end and now the front-end editor is working (see screenshots).

Please let me know if it worked for you or if you need more help.

Kind regards,
Diego

May 17, 2019 at 5:15 pm #3836203

ziga pipan

wow man, I didn't even think it was solvable. great work! many thanx!

May 17, 2019 at 5:30 pm #3836251

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there, I'm glad to hear that the issue is solved =)

Please contact us if you need our help in the future with WPML. We will be more than happy to help.

Cheers,
Diego

July 8, 2019 at 8:25 am #4159917

ziga pipan

hey

sorry to reopen this ticket, but I have the same issue on another site, and this time your fix does not work 🙁

ziga