This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by rickv-12 11 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
October 11, 2018 at 10:18 am #2807524

rickv-12

When trying to use the Settings and Translation Management menus, it gets "whited out", as if a pop-up is trying to show. However, there is no pop-up, so I can't make it go away and I'm stuck being unable to use the menus.

October 11, 2018 at 5:15 pm #2809265

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

There are a few things we will have to go over and this might fix the issue you are currently having.

I will write the steps below.

❌ Before proceeding please make a full website and database backup! ❌

STEP 1

I have noticed that your website’s WP Memory Limit (which is different than the PHP memory) is 40MB.

We will need to increase that as the minimum requirements for WPML are 128Mb:
https://wpml.org/home/minimum-requirements/

Please add the lines below to the top of the wp-config.php file to increase WP memory:

/** WP Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly. If you can get even higher values It would be great.

Please try again to use the Settings and Translation Management menus and see if this fixed the issue.

STEP 2

I can also see that there are a few plugins currently active on your site that might create this issue.

Please clear/delete all the existing cache on the site right now (you might have to do this in the settings of each of these plugins) and then disable each of these plugins:

- WP Fastest Cache
- Proxy Cache Purge

Please try again to use the Settings and Translation Management menus and see if this fixed the issue.

Let me know how it goes and if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

October 12, 2018 at 11:59 am #2811843

rickv-12

Hi Mihai,

The above steps did not work (although interestingly, it seems my site is faster after editing the wp-config).

I think I have had this problem before and found an answer somewhere, but I can't find it anymore on the forums. Are there any pop-ups that might occur on these pages?

October 15, 2018 at 1:42 pm #2817792

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

No, no popups should occur when visiting those pages.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

October 24, 2018 at 1:36 pm #2846534

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I spent some time on your site and from what I can see, I am able to access WPML > Settings or WPML > Translation Management without seeing any pop-up or obstruction.

Can you please check and see if this still happens for you?

Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit, so if you like, make use of “upload an image” below the comment area and please show me what it is showing for you.

I will be waiting for your response.

Kind regards,
Mihai

October 24, 2018 at 2:38 pm #2846873

rickv-12

Hi Mihai,

Of course, see the attachment! Sometimes it takes a second to get to this screen, as it first loads it without the "whitewash".

October 24, 2018 at 4:06 pm #2847223

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I think we are looking at 2 different websites.

I was testing this on the dev site (hidden link) you gave me access to. Are we talking about the same website or you are testing this on the live site?

Let me know.

October 25, 2018 at 6:35 am #2848790

rickv-12

Hi Mihai,

This happens at the live and the dev site.

October 25, 2018 at 1:21 pm #2849936

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

For me, it works perfectly on the dev site.

I spent some good amount of minutes on your site and I have been going through different WPML pages, including the Settings and the Translation Management submenus. They work perfectly and no layer appears.

I will attach some screenshots, too.

1. Can you please log in with the credentials you gave me and see if the issue is still happening?

2. If it is still happening, I am taking into consideration that there might be one or more browser extensions that you have installed on your browser and those ones might be causing this.

Please test this on another browser and let me know if it is still happening.

I will be waiting for your response.

Kind regards,
Mihai

October 26, 2018 at 2:30 pm #2853281

rickv-12

Hi Mihai,

Thanks for looking into it. When I login using the credentials I gave you, everything works fine for me too... The only difference I could find, was that Jetpack was attached to my account. I deactivated that plugin, but the issue remains.

I loaded the page with page inspector on and spotted that there actually is an overlay loaded (<div class="overlay"></div>) and that WPML is trying to display a welcome notice (bottom right hand corner). I guess it is only trying to show it to me, because I activated WPML. Sadly that also now makes me the only one not being able to use it properly. How can I dismiss this popup?

October 29, 2018 at 1:19 pm #2858115

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

My pleasure, no worries at all!

Hmm, so if it doesn't happen anymore when you are on my testing account, then this is confirming us that the issue is somehow related to your WordPress account.

What we could try is that I could add you as a translation manager and let's see if that changes anything (however, I would need to know the WordPress account id that you are using because you have multiple users and I already see one added as a translation manager and I'm afraid that it might be the exact one you are using) - I will set your next reply to be a private one so that you can tell me the username that you are using.

Unfortunately, there's no way to remove that notification for a specific user but as a quick solution I would recommend would be for you to simply create a new admin account and use that one instead; obviously this would be recommended only if it will still not work after we try the "Translation Manager" user level after I added you as a translation manager (and this also in the case where the current user that I see in the Translation Management panel would not be the one you are using right now - the one where you experience this issue).

I will be waiting for your reply.

Kind regards,
Mihai

October 31, 2018 at 7:54 am #2864651

rickv-12

Hi Mihai,

I tried your suggestion on the live site (I can login to your account of course ;)). As it turns out, the issue is not linked to my account, but happens to any account that has the Translation Manager role assigned. You can check for yourself on the test site: add yourself as a Translation Manager and see what happens! I have a third administrator account to be able to remove the role again.

October 31, 2018 at 12:41 pm #2865708

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I was able to reproduce the issue for my account, too, after I set it as a translation manager account.

After spending some time on the site, I got to the point where I disabled all the non-WPML plugins to see if the issue persists.

If you will log into my account now, you will see exactly the screen I am attaching you here as a screenshot.

So now we have a confirmation that this is caused by one of the plugins you are using that might not be compatible with WPML. However, maybe after you follow what the pop-up information shows you, things will work out fine even with all the plugins you were using enabled.

Above all though, it is important to find out what is the plugin that is causing this issue.

I suggest that you would enable the plugins back, one by one, and after each enabling of a plugin, test if the issue is still happening. This will help you find the one that is causing this.

Let me know how it goes. I will be waiting for your reply.

Kind regards,
Mihai

October 31, 2018 at 2:01 pm #2866144

rickv-12

Finally! The culprit was "WP Disable". I had "Admin notices" turned off. Usually, these are the annoying messages on top of the screen, but apparently this also counted as an admin notice. Turned it off and now I can use it. Thanks so much!