This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Can't view translated pages. Get redirected to home page. Solution: When using the non-latin letters in URLs, coupled with URL language parameter as a WPML language setting, it may not work properly.

This topic contains 7 replies, has 2 voices.

Last updated by eugeneK-6 2 months, 3 weeks ago.

Assigned support staff: Bruno Kos.

Author Posts
July 23, 2019 at 6:41 am #4263061

eugeneK-6

I am trying to: I am trying to translate all my pages but even after it shows 100% complete, I cannot view the translated page. It links me back to the home page. As such, i am not able to link the translated pages to the menu either.

Link to a page where the issue can be seen: hidden link

I expected to see: The korean translation of the page after i switch the language

Instead, I got: A link to my home page with a strange query string. (hidden link)

July 23, 2019 at 9:15 am #4264459

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

When this happens, the first thing we need to check if there page has a status of being published. Because if the page is not published and you try to visit it, it would take you to the homepage.

See the image on how you can check this and do it yourself. Make sure to choose the correct language page listing.

Regards,
Bruno Kos

July 24, 2019 at 2:32 am #4269623

eugeneK-6

Hi Bruno,

Thanks for responding! I've checked and all pages are 'Published'. However, i still cannot view the translated pages or make sure they link correctly on the menu.

Please help!

July 24, 2019 at 6:18 am #4270539

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

July 24, 2019 at 9:22 am #4272397

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

How about now?
hidden link

I changed the slug here into "team", as it is on Chinese as well. When using the non-latin letters in URLs, coupled with URL language parameter as a WPML language setting, it may not work properly.

Regards,
Bruno Kos

July 24, 2019 at 9:29 am #4272437

eugeneK-6

Ah! Thanks for your help. Will do that for the rest of the pages. Will assume that once i do that everything will work fine. Let me know how i can leave you a positive review.
Thanks!

July 24, 2019 at 9:55 am #4272663

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I'm glad to hear that you are satisfied with the solution!

You can simply close this ticket, mark it as resolved and put your feedback there.

Regards,
Bruno Kos

July 24, 2019 at 10:07 am #4272779

eugeneK-6

My issue is resolved now. Thank you!