If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by marcH-8 5 years ago.

Assigned support staff: George Botsev.

Author Posts
October 21, 2014 at 8:46 pm #496517

marcH-8

I am trying to: set up the theme with the theme options

I visited this URL: hidden link

I expected to see: the quick search with 4 or 5 components

Instead, I got: only 3.
I have this problem: the quick search of the estetico theme does not work due to the multilanguage bug of wpml. I can set up the components, but then they are not saved. When I switch the language, they are gone.
The carousel.php should display the featured accommodations, but it shows each accoommodation in EACH language!! So, I end up with one accommodation shown in 3 different languages!

October 22, 2014 at 9:43 am #496823

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Hello and thank you for contacting us.
Can you elaborate a little more about the issue?
Have you checked with the theme developer for theme update?
I have visited the link but there is just blank page. Could you provide a screenshots illustrating your issue?

October 22, 2014 at 12:36 pm #497018

marcH-8

Update: BLANK PAGE RESOLVED !!

Hi George,

right now there is indeed a blank page. I have a problem with the website. I don't know why, it got blank after I updated a page. I am investigating this and it should be resolved soon.

For the carousel.php problem: I have contacted the theme author and he said he will investigate this problem.

Tell me what you need to know.

I repeat the problem if it was not clear enough. The theme has a carousel option to display properties on the homepage (or whereever you place the carousel). The component is called "properties carousel" and I think it's the Visual composer Karousel. Anyway, I think the problem is with WPML, because the theme has also other problems with WPML, such as the quick search (see other post).

So, when I use this property carousel component, it should display the featured properties. It displays them, but ALL of them, in all languages. So, when I am on the English homepage, it displays one property in 3 languages (German, Italian, English). It is supposed to show only the english one of course...

thanks marc

October 22, 2014 at 1:02 pm #497051

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

The blank page issue could be resolved by following this: http://wpml.org/errata/maximum-function-nesting-or-allowed-memory-size-exhausted/
Or by updating to our latest beta - 3.1.8 beta 4. If you are using WordPress 4.0 and planning to use it as a shop - currently this is the best option.

Please remember to backup your database first before you proceed! You can use a plugin for this if you like (example: http://wordpress.org/plugins/duplicator/)

For the carusel problem, I think that the theme might be responsible, because of the way the posts are addressed.

October 22, 2014 at 2:15 pm #497135

marcH-8

Hi George,

I have edited my post, but I guess it was at the same time when you replied. The blank page was a problem of the functions.php in child theme. I fixed the problem.

Please see the screen shot in my post above, I have added it to the post. It shows both problems, the quick search box and the carousel. The theme author is not very helpful.. 🙁

thanks, marc

October 22, 2014 at 2:39 pm #497175

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

I need to request temporary access (wp-admin and FTP) to your site – preferably to a test site where the problem has been replicated if possible – in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

October 22, 2014 at 4:23 pm #497296

marcH-8

short note: I think I fixed the quick search problem. In the settings for the search component you have to move the desired components from left to right. Well, if you move them below the existing components, it doesn't work and it resets. You have to move them far to the right, so that they place automatically below the others. Then it works!!!

So, I guess that the quick-search problem is solved!! Now only the carousel problem remains...

thanks, marc

October 23, 2014 at 8:05 am #497657

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+02:00)

Please consider using our latest version 3.1.8.1.
For the slider, I think that you require here a custom work, that is beyond the scope of this support.
In your custom child theme you are getting all of the featured properties in the slider.
You have to filter the request to get the appropriate language only, perhaps by using our api code and the function icl_object_id.
You can read more here: http://wpml.org/documentation/support/creating-multilingual-wordpress-themes/language-dependent-ids/

November 7, 2014 at 8:45 am #507447

marcH-8

all resolved, thanks.