Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 20, 2018 at 2:17 pm #2197057

fulvioP

I am trying to: have the same carousel translated in english and espagnol.

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: the carousel with titles not traslated and with one image lost (FUSTELLA).

Let me know

May 21, 2018 at 6:52 pm #2203773

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @fulviop, welcome to the WPML support forum!

It seems to me that you are using WpBakery Page Builder, Please take a look at this link to see how to translate content from page builders: https://wpml.org/documentation/translating-your-contents/page-builders/

If it still does not work, you can send me access to your WordPress dashboard (admin login and password) or a copy of your website using Duplicator. I can try to reproduce the issue on my local server.

IMPORTANT: Please use the private field to send sensitive data.

All the best,
Diego

May 22, 2018 at 12:36 pm #2208043

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi @fulviop,

I tried logging in WordPress several times but it says login or password is not correct.

Could you please check?

PS: don't forget to use the private field.

Regards,
Diego

May 22, 2018 at 5:00 pm #2210485

fulvioP

Please try again now and let me know.
Thank you

May 22, 2018 at 8:41 pm #2211692

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi @fulviop,

The reason for the image not being displayed was this field with incorrect information (see attachment) - this should be the image ID.

For some reason WPML did not recognize the slide title strings. However, it is possible to translate the titles using the native WordPress editor (and the page builder) instead of the translator editor. To do this, follow the steps below:
1) Login to your WordPress dashboard and go to Pages > All Pages.
2) In the top menu, switch to the English language
3) Click on the "DIE CUTTING PDF76E Formato 50×70 WITH STRIPPING UNIT" title. It will open the page edit screen with the default WordPress editor and page builder for the English version. This way you can edit the missing fields

Please let me know if this solves the issue.

All the best,
Diego

May 27, 2018 at 10:00 am #2234612

fulvioP

Now I have the image agin,
but I don't touch nothing.
If I cahnge the name as you told me I lost the image again. (Vc_single image in tranlation I put a name I lost the image link > No image in front end).
Regards

May 28, 2018 at 1:05 pm #2238653

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

This is because you are using the Translator Editor instead of the WordPress Native Editor. To use the native editor, you need to follow the steps below:
1) Login to your WordPress dashboard and go to Pages > All Pages.
2) In the top menu, switch to the English language
3) Click on the "DIE CUTTING PDF76E Formato 50×70 WITH STRIPPING UNIT" title. It will open the page edit screen with the default WordPress editor and page builder for the English version. This way you can edit the missing fields using the page builder.

You can also disable the Translator Editor if you want on WPML > Translation Management > How to translate posts and pages selecting the Create translations manually option, but this will affect all pages.

PS: On the translator editor, you need to keep the same values on the Vc_single image fields, because they are the ID of the images (not the title).

Please let me now if it worked for you.

Regards,
Diego

May 29, 2018 at 7:19 pm #2248061

fulvioP

Ok thank you for your support.
I'll try to edit the translated page.
Thank you