Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 2 voices.

Last updated by Laura 3 weeks ago.

Assigned support staff: Laura.

Author Posts
November 29, 2019 at 9:29 am #5041287

pamelaB-5

I am trying to:

Acces the cart and checkout pages in English when I select English with the language switcher.

Link to a page where the issue can be seen:

hidden link > Select English > Click the Cart of Checkout > Language switches to the default language (Dutch).

I expected to see:

Language of the Cart and Checkout pages in the same language as the selected language.

Instead, I got:

Cart and Checkout pages are shown in the default language.

December 6, 2019 at 1:21 pm #5084021

pamelaB-5

Hello Laura,

We've updated everything to the newest version but sadly the problem still persists.

Kind regards,

Pamela

December 6, 2019 at 2:46 pm #5084615

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Pamela,

I can still see the issue, thank you.

I'd ask you to try this too:
- activate "Look for strings while pages are rendered" in WPML > String Translations
- refresh the home page
- deactivate the option above
- go to "translate strings in admin screens" (also from WPML > String Translations) and click apply

If it doesn't work, please try to install your theme here and see if you can reproduce the issue
hidden link

December 6, 2019 at 3:11 pm #5084783

pamelaB-5

Hello Laura,

I followed your steps but the issue still persists.
I will try to reproduce the issue when I have time.
I'll keep you updated.

Kind regards,

Pamela

December 7, 2019 at 8:09 am #5086569

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Pamela,

also please check these errata and see if they apply to your case:
- https://wpml.org/errata/default-locale-for-a-language-should-always-use-underscore-and-not-a-dash-hyphen/
- https://wpml.org/errata/in-some-cases-some-strings-are-not-translating-properly/
- https://wpml.org/errata/hosting-with-read-only-folder-wp-content-languages-issues-with-wpml-string-translation/

December 19, 2019 at 11:40 am #5163117

pamelaB-5

Hello Laura, the errata don't apply to my case.
I see the link you provided for me where I can install the theme has expired.
Could you activate it again?
I will install the theme right away.

December 19, 2019 at 2:15 pm #5164027

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi Pamela,

please use this link: hidden link

December 19, 2019 at 2:34 pm #5164165

pamelaB-5

Hello Laura, I installed the theme and activated the language switcher but the English flag doesn't show up.

December 19, 2019 at 3:19 pm #5164355

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I can see the flag, but at the moment it seems there are no content in English. Did you run the WCML wizard to create shop pages in the second language?

December 19, 2019 at 3:52 pm #5164691

pamelaB-5

Hey Laura, it appears the problem isn't in effect on the WPML sandbox.
What is the next step?

December 20, 2019 at 11:15 am #5170201

pamelaB-5

I noticed that the english cart page is loading when I switch languages and hover over the cart, but after a couple of seconds this gets replaced by the Dutch cart page. Also on mobile this problem isn't present. So we think this is an AJAX problem. Does the URL change from current to primary language?

December 20, 2019 at 1:12 pm #5170701

pamelaB-5

I migrated the site.

December 21, 2019 at 1:02 pm #5175547

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I can see the issue happens in the copy of the site too, so it could be related to a 3rd party plugin.

The problem I have with your copy is that I found an admin user (Hybridd_rdf) but it's not the super-admin so I can't uninstall plugins to do further checks.
Can you please add super-admin credentials?

However, I noticed that if you change language, at first the correct URL en/cart/ is available, then when the loading of the page is completed the Dutch one appears. It might be related to some kind of Java Script. I noticed you have Async JavaScript active, it might be the culprit but to say it I should try to disable it first.

December 23, 2019 at 10:06 am #5183413

pamelaB-5

Hello Laura,

How do I add the Super Admin credentials?

Kind regards,

Dylan

December 23, 2019 at 12:07 pm #5184209

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

sorry, I'll enable a private reply.

The topic ‘[Closed] Cart and checkout pages show default language after switch’ is closed to new replies.