This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Carlos Rojas 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 26, 2018 at 6:42 am

alexandrosA-3

I am trying to: switch language and check the cart / or fill the cart in a secondary language (not English)

Link to a page where the issue can be seen: hidden link

I expected to see: the cart contents carry over when changing language. Or cart contents increase when using a secondary language.

Instead, I got: When I tried to switch language and check the cart / or fill the cart in a secondary language (not English) my cart was emptied. The cart works fine in english but is getting reset if I use any other language.

September 27, 2018 at 12:01 am #2768866

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to ask you to follow this steps:
- Create a full backup of the site.
- Update all outdated plugins.
- Flush all cache memory,
- Finish the translation of the products.
- Go to Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link (bottom right) -> Sync all products.

Could you tell me if the issue persists?

2.- Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Kind regards,
Carlos

September 27, 2018 at 2:21 pm #2770812

alexandrosA-3

Thank you.

However these steps did not fix the issue and it continues to appear. I see that when I use a signed up user that issue does not appear. It only appears when a user is not signed up and is browsing the site as a guest. Do you have another suggestion?

Thanks.

September 27, 2018 at 3:18 pm #2771019

alexandrosA-3

Further testing proved that on my testing "staging" site, which is an exact replica of the original, the issue does not appear. The cart works fine between translations there.
hidden link

Admin credentials are the same there. You may use it to troubleshoot if you may. Thank you.

September 27, 2018 at 8:02 pm #2771715

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Before I log in the site I kindly ask you to flush all cache memory, specially WPEngine cache memory and double check if the issue persists.

Regards,
Carlos

September 28, 2018 at 7:20 am #2772736

alexandrosA-3

Hello,

I cleared the cache and the issue persists.

Thank you.

September 28, 2018 at 2:03 pm #2774147

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your feedback.

I would like to ask you to follow this steps:
- Finish the translation of the products.
- Change the slug of the cart page in Greek to a plain text like 'cart-greek' -> Save the changes.
- Go to Settings -> Permalinks -> Re-save the permalink structure.
- Flush the cache memory.

Could you tell me if the issue persists?

Rgards,
Carlos

October 3, 2018 at 12:18 pm #2784470

alexandrosA-3

Hello,

It seems that the issue now is at last resolved.
I had the product translation all finished so I did not do that step
I changed the slug of the cart page to use only latin letters instead of greek letters (maybe that fixed it? I thought I could use any UTF-8 char for a url). Now the cart page in english is: /cart and in greek it's /el/cart

I did the same for the checkout page.

I resaved the settings->permalinks and flushed the cache

The cart now works just fine in greek.

Does that mean that I cannot use full UTF-8 urls for WPML?

Thank you.

October 3, 2018 at 6:06 pm #2785445

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

There is a known issues with transients and characters that aren't latin in the slugs of the Woocommerce pages. Our developers are working on a solution that should be included in the next release of the plugin.

Best regards,
Carlos