This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Carlos Rojas 2 months, 2 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 4, 2019 at 11:16 pm #4337057

reneU-2

After changing the language, the cart gets emptied. All products are translated. The Cookie is set and under Woocommerce WPML and "Sync content of shopping cart when changing languages" is also checked. If works only when changing currency but not languages.

August 5, 2019 at 5:02 pm #4342133

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins and themes.
- Flush any cache memory that might exists.
- Go to WPML -> Languages -> Make sure that the Ajax cookie is activated.
- Go to Woocommerce -> Woocommerce Multiingual -> Status tab -> Fix any error that appear.
- Go to Woocommerce -> Woocommerce Multiingual -> Settings tab -> Select all options -> Click on 'Apply' button.
- Go to WPML -> Support -> Troubleshooting link -> Apply the steps highlighted in the attached image.

If the issue persists then:

- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos