This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bruno 2 years, 9 months ago.

Assigned support staff: Bruno.

Author Posts
June 7, 2017 at 12:11 pm #1293061

ryan@eliberare.com

I am trying to:

URL of (my) website where problem appears:
zuriell.com

I expected to see: cart with product after i add product to cart

Instead, I got: empty cart after I add it.

I have the following plugins installed and activated: hidden link
But when i activate "WPML Translation Management" when i add product to cart , the cart is empty.

June 8, 2017 at 12:43 pm #1294016

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for contacting us.

For your screenshot, it looks like you have multiple outdated plugins. Please, could you update all the WPML plugins and check if the problem persists?

Note that it is recommended to fully backup your site before updating your plugins.

After updating all the plugins, please let me know if the problem persists.

Thank you.

June 8, 2017 at 3:42 pm #1294236

ryan@eliberare.com

If i update the plugins, after I add to cart something, it will show empty cart.
Also now is same problem, but deactivation of "WPML Translation Management" made the site to work.
that site is live

June 8, 2017 at 6:18 pm #1294379

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Please, what is the version of WordPress are you using? I would like to know more about your installation. Can you please provide your WPML Debug information in the debug field below? http://wpml.org/faq/provide-debug-information-faster-support/

Also, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please, can I install the Duplicator plugin ( https://wordpress.org/plugins/duplicator/ ) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

June 13, 2017 at 7:05 am #1296933

ryan@eliberare.com

I tried updating all modules, theme, and WP to latest and won't work

June 13, 2017 at 1:57 pm #1297381

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you for the credentials. I see that some of your plugins are still outdated on your current installation.

Also, I've noticed that you are using 64MB of memory. The WPML requires at least 128MB: https://wpml.org/home/minimum-requirements/

Please, could you increase the memory limit for WordPress? To do it, please open the wp-config.php file in the root of your WordPress installation and after the opening PHP tag, add these lines:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

E.g.:

<?php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Then save the file and using your FTP client, upload wp-config.php to your server. After increasing the memory limit, please let me know if the problem persists.

If the problem persists, please, can I install the Duplicator plugin ( https://wordpress.org/plugins/duplicator/ ) to make a copy of your site and install it on my test environment? This will help me debug the problem.

Thank you.

June 13, 2017 at 2:10 pm #1297404

ryan@eliberare.com

Changed max memory size, but didn't helps.
Please do install plugin

June 13, 2017 at 6:55 pm #1297672

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. In my testing environment, after I upgraded the WPML, WooCommerce and WooCommerce Multilingual plugins, this issue has been resolved. The other plugins I did not need to update.

Ideally, you should create a testing environment to see if this will work properly on your testing site. If so, you can upgrade your production environment as well.

This may have been a bug in the past and fixed on newer versions.

Thank you.

June 14, 2017 at 11:59 am #1298145

ryan@eliberare.com

Ok, made the site updates just to the plugins you mentioned.
Works, BUT WPML Translation Management still messing up the add to cart process.
I need to disable this plugin for add to cart work.

June 14, 2017 at 8:41 pm #1298613

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Sorry, but I did not understand. After you updated the plugins I've mentioned above, has the problem been solved?

About the process of adding the product to the cart, I've followed the default steps. What is the problem that is happening when you add the product to the cart?

Thank you.

The topic ‘[Closed] Cart empty’ is closed to new replies.