This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 3 voices.

Last updated by jernejO 5 months, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
April 16, 2019 at 10:15 am #3620931

salvadorC

I am trying to: get into the page of a brand. I´m using WooCommerce Brands (https://woocommerce.com/products/brands/)

Link to a page where the issue can be seen: hidden link

I expected to see: something similar to this: hidden link

Instead, I got: a blank page withe the following error "Catchable fatal error: Object of class WP_Error could not be converted to string in /usr/home/pecas.com/web/wp-includes/pluggable.php on line 1282"

April 16, 2019 at 6:24 pm #3624645

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If you disable WPML plugins, does this error message go away? If so, please update to the latest versions of WPML and see if this resolves the error.

Also, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and WooCommerce Brands, then temporarily change the theme to a default WordPress such as TwentyNineteen. With these settings, is the issue resolved?

April 17, 2019 at 6:40 am #3627529

salvadorC

Hi Lauren.
I´ve done what you tell me but the problem persists.
Thanks!

April 17, 2019 at 12:43 pm #3630801

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If the error message is still showing when WPML is disabled, then I don't think the message is related to WPML. If you can confirm that the error goes away when WPML is disabled, then I will be happy to continue troubleshooting. Otherwise, I suggest reaching out to the WooCommerce Brands plugin for further assistance.

April 18, 2019 at 6:32 am #3636325

salvadorC

Hi Lauren.
I´ve deactivated WPML and everything works fine. The problem is because the plugin.
Thanks!

April 18, 2019 at 12:38 pm #3639171

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

April 26, 2019 at 8:30 pm #3693265

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I found that if you go to WPML -> Settings -> Taxonomy Translation and set Brands to either Translatable Only or Translatable - Fallback to default, the error message is resolved.

Please let me know if you need any further assistance and I will be happy to help.

April 29, 2019 at 7:03 am #3700409

salvadorC

My issue is resolved now. Thank you!

October 8, 2019 at 12:57 pm #4715543

jernejO

When I do what's suggested it says "Error: data not saved". Any help appreciated.