This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 29 replies, has 3 voices.

Last updated by Radu 3 weeks ago.

Assigned support staff: Radu.

Author Posts
March 18, 2020 at 8:33 am

autumnW

I am trying to: i have added links to buttons and text on page to catergories but they do not update to the correct verison of the translated page

they either go to still go to the english version or 404 page

Link to a page where the issue can be seen: home page

I expected to see:

Instead, I got:

March 18, 2020 at 1:21 pm #5711289

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I will be helping you. Could you please indicate which button I should be focusing on to see the problem you describe?

I´m sorry but I don´t know German. Maybe you can upload a screenshot?

THanks

March 23, 2020 at 7:47 am #5738549

autumnW

Hi Yvette

The button is working correctly on the spanish version

no problem we can look at the view furniture button and on the english and german site

I am having the same problem across the site

but in the top banner i have a white button with all furniture which should go to the furniture category

when i change the language of the website to german the button doesn't update to the furniture category version in german

I have all the categories translated

Also on the home page i have buttons further down the page

on the spanish site they seem to be working correctly

but on the german for example they go to the english version of the page

retroeurope.net

March 23, 2020 at 1:12 pm #5741379

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

These are "internal" links that I can see are still pointing to the original langauge text when I open the "Elementor" view of the translated page.

It´s not clear why these internal links are updated in the other langauges but not in DE.

You can fix this by temporarily going into the ELementor editor for the translated page and updating the links with the correct DE language target link.

You can also try to update your internal links here:
WPML > Settings > Translate Link Targets

I started this job but the number of links seemed disporportinately high and I ended the job and opted to just update this one link withn the Elementor editor as described above. This worked.

You would need to do this with the other buttons.

March 24, 2020 at 5:28 pm #5753277

autumnW

Hi Yvette

Thnakyou or your reply

Translate Link Targets

I have tried this part 3 times now and it wont finish the highest number i go to was 80000

any ideas how to get it to run a full cycle

108218 seems a lot of links is that right ?

March 25, 2020 at 10:26 am #5759185

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I agree that seems like an insane amoutn of links. There must be something wrong there.

In the interest of moving your project forward - while we look at the reason why the internal links are going bonkers, can you work with updating your target page links manually as I described?

If so, then knowing you have a way to proceed, we can focus on the problem of these internal links. For this, please send me a copy of your site as per this article:
https://wpml.org/faq/provide-supporters-copy-site/

Once you have the Duplicator package set up, just let me know and I will connect to your site and download the package directly from there.

March 25, 2020 at 5:49 pm #5763273

autumnW

The plugin is installed.

I will work on the manual links tomorrow as you suggest.

Could you also look in to something for me i have a completed ticket but the fix is being added to the wpml 4.8

The issue has been there for 1 month now and i am not getting any reply from Rohan i am not sure if he is still at work i have spoken to another team member Shekhar Bhandari who has also messaged him

I just need a time scale for the release and if we need to make another plan

Thankyou

March 26, 2020 at 4:43 pm #5772035

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

DO you mean ths ticket
https://wpml.org/forums/topic/translate-the-product-titles-for-woocommerce-products-by-attributes-variations/

If so, I can see in the notes that the new release is rolled out to 100% of clients by today. So this should be available to you now.

March 27, 2020 at 7:50 am #5775995

autumnW

Hi Yvette

Yes new release came out so we are working to sort the issue

thankyou for looking into this for me

i await your update on the issue of the links

thankyou

March 27, 2020 at 11:22 am #5777819

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

For the links issue, I understand that you are going to proceed with manual translation and then send me a Duplicator copy of your site so we can investigate why there are so many reported internal links to update.

Right?

So I am opening the private area for the copy of your site when you have it.

March 30, 2020 at 1:55 pm
March 31, 2020 at 8:19 am #5801867

autumnW

Hi Yvette

I have started as you have suggested

But i am ending up with a mix of classic editor and advanced editor translations

In the footer and header this is an issue as now i have to change all the links there and is it classic editor

they all have changed back to english is this correct?

is there a way to transfer them back to the advanced editor in the future ?

March 31, 2020 at 8:35 am #5801969

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. You wrote: "...But i am ending up with a mix of classic editor and advanced editor translations...they all have changed back to english is this correct?"

Hmmm. I´m not sure I fully understand. Could you send me a link to an exampe or include screenshots of what you mean?

2. You asked: "...is there a way to transfer them back to the advanced editor in the future?"
I don´t think so, unfortunately. The two editors are separate intermediate servers that cannot see the work already done by the other respectively.

Normally, with the ATE, the internal links would be updated with the internal links tool that seems to not be working well for you for some reason.

Does this answer your question?

March 31, 2020 at 8:40 am #5802019

autumnW

I was able to get it back to advanced but making a minor update on the template and then pressing the circle

have you been able to look at the duplicated site i sent ?

April 1, 2020 at 12:41 pm #5812937

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Yes, I installed your site on the local server and the same behaviour happens. I am currently prepping a ticket to escalate this to our 2nd tier support group.

The topic ‘[Closed] category links not updating to other languages’ is closed to new replies.