Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: When I translate a post, the category assigned is in the default language instead of the translated category.

Solution: This issue comes from "Auto-adjust IDs" option being turned ON. If you turn that off in your WPML -> Languages setting, it works properly and the correct category is assigned to the translation.

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Lauren 2 years, 8 months ago.

Assigned support staff: Lauren.

Author Posts
December 8, 2017 at 10:45 pm #1453266

andreyO

Hello,

I have installed latest WPML plugin versions.
I have several post categories in default language (German).
I translated categories with WPML -> Taxonomy Translation.

Each time I save translated post into English, category of translated post changes to German (default) language category.

When transalting post I get also section Categories to be translated (see screenshot).

Regards,
Andrey

December 11, 2017 at 6:54 pm #1454748

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

If I understand correctly, when you save a post to English (your secondary language), the category assigned is the German category name. Is this correct?

If you go to WPML -> String Translation and look for the string "Categories", which language is the string assigned to?

Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

December 11, 2017 at 8:51 pm #1454861

andreyO

> Please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

>> DONE

> If I understand correctly, when you save a post to English (your secondary language), the category assigned is the German category name. Is this correct?

>> Yes (see screenshot)

> If you go to WPML -> String Translation and look for the string "Categories", which language is the string assigned to?

>> All entries are English strings (see screenshot)

December 11, 2017 at 9:03 pm #1454873

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

December 12, 2017 at 6:34 pm #1456036

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Can you please tell me which screen you were viewing in the langpost.jpg image?

I was unable to recreate this issue. To test, I first created a test post in English and assigned English categories. In the list of posts, the category displayed the correct English category.

I then created a test post in German (titled Test Post German) and assigned German categories. I translated this post to English and assigned the English categories. Again, in the list of posts, the categories display the correct English categories. Please see attached screenshots.

Can you please outline the steps you are taking when you are seeing the issue?

December 12, 2017 at 9:27 pm #1456160

andreyO

Hi,

langpost.jpg is a list of all posts, when you switch to English (upper panel, where you see the British flag).

I went all the steps through with the new category, so you can now even see the status, how it looks like after all.

1) Make sure you selected German language
1) Create new category in German "Test-Kategorie"
2) Translate the category into English with WPML ->Taonomy translation-> Categories into "Test category"
3) Sync all the categories WPML -> Taxonomy translation->Sync
4) Create new post in German "Test Beitrag", assign category "Test-Kategorie", publish post
5) Translate post into English "Test post" (I did it directly from post Edit-View) (see screenshot translate_post.JPG), press "publish and close"
6) Now go to overview, see new post "Test Beitrag"
7) Switch to English language (upper panel)
8) In the overview see the post "Test post". It has already now category "Test-Kategorie" (see screenshot post_overview_EN.JPG — the same view and status as langpost.jpg)
9) Assign correct category (I did it with Quick Edit) "Test category", i the overview see the changes
10) Switch to German language
11) Edit English translation (in post overview press pen under English flag), change body text, press "publish and close"
12) Switch to English language again, see in overview, that the post has again category "Test-Kategorie" (as on post_overview_EN.JPG)

December 13, 2017 at 3:10 pm #1456914

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I followed your steps exactly but am unable to recreate the issue. Please see my attached screencast. I create the category and translate it. Then create a post, assign the category, and translate the post. At all times, the English post shows the English category. I don't have to use quick edit to assign a different category.

Screencast: hidden link

After reviewing my screencast please let me know if I am missing any steps or doing anything different.

December 13, 2017 at 3:32 pm #1456946

andreyO

Hello Lauren,

the only difference between your steps and mine I've noticed, and this is a reason of the problem, is that I used page builder for content part.

I've changed your post "Lauren Test Post DE" to use page builder and could reproduce the problem.

BR,
Andrey

December 14, 2017 at 3:45 pm #1458089

andreyO

Hello Lauren,

do you have any news for me?

BR,
Andrey

December 14, 2017 at 4:12 pm #1458149

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this to our 2nd Tier Development team. I will be working with the developers to find a resolution and will keep you updated here. Thanks for your patience while we continue to troubleshoot.

December 21, 2017 at 9:37 pm #1464116

andreyO

Hello Lauren,

we would like to process with translating our website into other 4 languages, that's why I'd like to ask you, wheather you found any solution for us after one week troubleshooting.

Best regards,
Andrey

December 22, 2017 at 5:28 pm #1464809

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Our developers found that this issue comes from "Auto-adjust IDs" option being turned ON.
If you turn that off in your WPML -> Languages setting, it works properly and the correct category is assigned to the translation.

Please let me know if you need any further assistance and I will be happy to help.

December 22, 2017 at 9:49 pm #1464920

andreyO

Hello

so instead to solve the problem, you are just offering me not to use one of the features, which I'm using right now, correct?

Well, this is not a solution for me, so I'd like to have another option.

Regards,
Andrey

December 26, 2017 at 2:01 pm #1465914

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Andrey, I apologize for the late reply, I was off for a holiday. I have escalated this to our developers once more so that we can work for a different solution for you. I'll reply here as soon as I have more information.

December 28, 2017 at 10:41 pm #1467648

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi Andrey, I spoke with our developers and have added a request to change the functionality, but I don't have a timeline of when it will be changed. At this time I'm afraid there is no other solution other than to disable "Auto-adjust IDs".

I wish I could have a better response for you. Please let me know if there is anything else I can do to help.