Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 3 voices.

Last updated by Jamal 1 week, 5 days ago.

Assigned support staff: Jamal.

Author Posts
November 14, 2019 at 10:39 am

matteom-42

I am trying to:

show the category page

Link to a page where the issue can be seen:

hidden link

italian version of

hidden link

I expected to see:

hidden link

like hidden link but translated

Instead, I got:

hidden link

November 15, 2019 at 3:31 am #4950977

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi There,

Are you still experiencing this issue?

When I visit your site I am able to navigate to hidden link as expected without being redirected.

November 15, 2019 at 9:10 am #4952169

matteom-42

now is ok, it fixed itself, but sometimes it broke again apparently for no reason... can you investigate why? it happened at least 2-3 times before

November 16, 2019 at 12:47 am #4957195

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hello,

I have taken a closer look and i was not able to reproduce this behavior.

If you are able to provide me with some steps on how I can reproduce it, it would be great so we can investigate this further.

At the moment I do see however that since both your category is named 'notizie' and that article starts with 'notizie' in the URL, if you misspell the category URL the article URL will be given higher priority by WordPress and WP will redirect you to the article URL.

For example if you type hidden link instead of hidden link you will be redirected to the Article instead.
This redirect is added by WP as a 301 redirect.

November 22, 2019 at 9:32 am #4995419

matteom-42

the issue just pop out on

hidden link

instead i see

hidden link

thank you

November 22, 2019 at 10:09 am #4995761

matteom-42

maybe i found out why, i removed the plugin No Category Base (WPML) in the staging environment expertsystem.mediamatik.com and i user the yoast seo remove category function

and it appear to work hidden link (http auth u:expertsystem p:bizupsrl)

but i read https://wpml.org/errata/yoast-seo-strip-the-category-base-does-not-work-in-the-second-language/

do you think is safe now to use the yoast seo functionality instead of the dedicated plugin?

November 22, 2019 at 10:53 am #4996399

matteom-42

update, i implemented the yoast seo solution in prod (expertsystem.com) and setting the category base in permalinks to . and regenerating them everything seems to be ok

if you want to investigate, i put a snapshot of the site with the issue in the staging environment (expertsystem.mediamatik.com)

November 23, 2019 at 10:28 pm #5005585

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Thank you for updating me!

I have tested it and it seems to be working as expected now.

November 27, 2019 at 9:17 am #5027331

matteom-42

no it's not, in staging it's still there

hidden link

redirects to

hidden link

and in PRODUCTION the bug returned suddenly this morning

November 27, 2019 at 4:09 pm #5030825

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

As Bobby is not available for a few days, I'll continue with you on this issue.

The errata should be solved from previous versions. As you are not using "category" in your categories URL, I activated that option in Yoast in the staging site and it resolved the redirect.

Would you like to test it on the production site?

Best regards,
Jamal

November 28, 2019 at 9:07 am #5034165

matteom-42

hi jamal, where is the option?

November 28, 2019 at 9:34 am #5034349

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello @matteom-42,

My apologies for forgetting the attached image, I just added it to my previous message.
The option is in SEO->Search Appearance->Taxonomies(tab).

Let me know if this resolves the issue.

Best regards,
Jamal

November 28, 2019 at 9:58 am #5034529

matteom-42

i don't think you read the full discussion beetween me and bobby, i will resume it for you

there's 2 ways to accomplish this

1) with the plugin No Category Base (WPML)
2) with the yoast seo functionality

but in production, from time to time, the problem suddenly returns by itself, and it's resolved by updating permalinks and clearing cache, i'll let you know when it appears again

November 28, 2019 at 3:32 pm #5037661

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for your feedback. I did read the discussion with Bobby, my apologies for missing the part where the issue came back again from time to time.

WPML does not try to do any redirects, so this is probably coming from the caching system or from another plugin.

Please, let me know when it get back, we'll investigate further.

Best regards,
Jamal

November 28, 2019 at 3:49 pm #5037823

matteom-42

i don't think is a redirect, it's a wrong slug query