This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 19 replies, has 2 voices.

Last updated by nikolajW 1 month, 1 week ago.

Assigned support staff: Riffaz.

Author Posts
September 4, 2019 at 7:07 am

nikolajW

I am trying to:
Update taxonomie.

Link to a page where the issue can be seen:
hidden link

I expected to see:
"Update taxonomy hierarchy" button

Instead, I got:
See nothing.

September 4, 2019 at 8:03 am
September 4, 2019 at 8:56 am #4509479

nikolajW

Hello, my Ticket got assigned, but there is nothing else to see...
I don't get what is going on. 😀

Regards

September 4, 2019 at 9:21 am #4509655

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

Yes, I am checking this.
I will update to you again once I find something.
May be within an hour or two.

Regards,
Riffaz.

September 4, 2019 at 10:50 am #4510247

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

May I ask?

1) Have you translated all the terms from WPML>>Taxonomy Translation screen? If so it is an expected result. We have to synchronize the hierarchy of terms after completing the translation of it. Please check the following documentation for more details.

https://wpml.org/documentation/getting-started-guide/translating-post-categories-and-custom-taxonomies/#synchronizing-hierarchical-taxonomies

2) Have you synced the taxonomy from WPML>>Taxonomy Translaiton>>your type/post >>Hierarchy Synchronization

3) Have you changed the position of a term? For an example from a top-level term to a child term. In this case, also we have to synchronize taxonomy translation hierarchy.

And, I am unable to check your site.
I see just a blank page when I visit to your site: hidden link
Do you have some kind of IP restriction security in your site?

Let me know.

Regards,

September 4, 2019 at 12:33 pm #4510919

nikolajW

My host told me that they don't restrict any country, but they have a blacklist for IPs. 🙂

I had similar issue with the blank-page and I din't know why that happened, but it seems to be fine again.
Please check it again.

I expected to see:
"Update taxonomy hierarchy" button, but there is no button under category.

I checked each point in the drop-down menu.
And only measure-units have 3 not translated strings.
And they some how can't be translated.
I entered the translation many times and saved, but the translation is disappearing. (Check the screenshot)

To your point, I can't only say, that I did translate many strings and pushed every save and synch button I could find. 🙂

September 5, 2019 at 6:45 am #4515741

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

That doesn't really update the taxonomy per see but it's hierarchy, so if you have added a child and added another child to the parent, for example, it will update its "position".

"Update taxonomy hierarchy" button, but there is no button under category.
- so when he has child term he should be able to see the button to sync??
- no, that button is only there in WooCommerce Multilingual. it's not there in WPML taxonomy translations (WooCommerce > WooCommerce Multilingual > Taxonomies (categories, attributes, etc)

but the problem you have is that you have some translations that are not translated, right?

Let me know which one is that, I am not quite sure about check which taxonomy here and where?

I guess that you think that the sync button will fix everything but it won't and you have complete the translations of taxonomies in proper places.

Let me know.

Regards,

September 5, 2019 at 10:48 am #4518529

nikolajW

Hey,

sorry but I don't get your point.

I'm not experienced enough with WPML to give you support in this case.
I checked every drop-dowm option in WooCommerce > WooCommerce Multilingual > Taxonomies.
Only the string on the screenshot are not translated and somehow don't want to be translated. 😀

A "Fix my issue"-button is a wish of every one. 😀
I only follow the warn-message which tells me to press the button.

If there is no button or it don't give the promissed result, the warning content should be changed.

How exactly may I help you? :/

Regards.

September 5, 2019 at 12:25 pm #4519279

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I logged in and checked your site.

This issue is escalated to our developers and will be fixed in future versions of WPML. Meanwhile, we have a workaround that in other cases solved this similar issues. For this workaround to work, you should know approximately how many terms you have in Products Categories. And then add this number to the following constant which you should add to the wp-config.php file of your WordPress installation.

define('WPML_TAXONOMY_TRANSLATION_MAX_TERMS_RESULTS_SET', '5000');

Please replace the number 5000 with a number that is a bit higher than the number of terms that you have.

This fixed the issue for many other users.

I tried to do this fix on your site but when I logged in to your FTP I do not see wp-config.php file.
I am not sure if you did something with that.
Create or fix your wp-config.php file and then apply the above solution.
Your issue will be fixed.

Regards,

September 5, 2019 at 12:28 pm #4519283

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

You should have your wp-config.php here: hidden link

September 6, 2019 at 12:42 am #4522211

nikolajW

Hey, I tried this, but it doesn't work.

September 8, 2019 at 12:39 pm #4531417

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I logged in to your FTP and fixed it.
The message is no longer displayed in your backend : hidden link

Please check and confirm.

Regards,
Riffaz.

September 8, 2019 at 2:07 pm #4531741

nikolajW

Hey,

it is important to know what you did. Otherwise I could without knowing undo your fix.

Btw. the issue still is visible.

Regards.

September 9, 2019 at 12:52 pm #4537219

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I add this line to your wp-config.php : hidden link

After adding that I did not see that message but it reappears now.
I escalated this to our developers.
Please be patient till we get back to you again.

Regards,

September 10, 2019 at 10:19 am #4543895

nikolajW

Thank yu very much.

This ticket now stays open, untill this issue is resolved?
How will I get notified, about the update?

The warning message is taking up a lot of space and distract me a lot.
Is there a way to use CSS to hide it in the back-end?

Regards