This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: When adding products to cart with plugin enabled takes over 6+ seconds. When String Translation plugin is disabled takes only 2-3 seconds max.

Solution: I applied this steps: - The troubleshooting steps in WPML -> Support -> Troubleshooting link. - Woocoommerce -> Woocoommerce Multilingual -> Settings tab -> Troubleshooting link -> Sync the products. - Settings -> Permalinks -> Re-saved the permalink structure. - WPML -> Theme and plugins localization -> Localization options -> Selected the 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' and 'Assume that the original language of all strings is English' -> Saved the changes. - WPML -> Languages -> Make themes work multilingual -> Deselected 'Adjust IDs for multilingual functionality' -> Saved the changes. - WPML -> String Translations -> Track where strings appear on the site -> Deselected 'Track where strings appear on the site' option -> Click Apply -> And in ''Auto register strings for translation' section -> Click 'Edit' button -> Deselected all the options -> Save the changes.

Relevant Documentation:

This topic contains 40 replies, has 2 voices.

Last updated by anthony pezzullo 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 16, 2018 at 9:22 pm

anthony pezzullo

I am trying to: When adding products to cart with plugin enabled takes over 6+ seconds. Plugin disabled takes only 2-3 seconds max.

Link to a page where the issue can be seen: hidden link

I expected to see: same latency when enabling plugin

Instead, I got: increased latency when plugin is enabled

August 17, 2018 at 1:05 am #2651716

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I applied some settings and the site was a little bit faster, however the main cause of the perfomance issue is the number of errors that appear in the Javascript Console of the browser (see attached image).

Kind regards,
Carlos

August 17, 2018 at 3:49 am #2652139

anthony pezzullo

Hi Carlos! My hosting service found the following problem associated to WPML. This is the message given: There is also an error asking you to contact WPML support:
We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

August 17, 2018 at 3:50 am #2652142

anthony pezzullo

Sorry this is the full message: We have detected a problem with some tables in the database. Please contact WPML support to get this fixed.

Duplicate entry '9fce0aecae80d0fcead2d1a2a63d597d' for key 'uc_domain_name_context_md5'
Array
(
[language] => en
[context] => admin_texts_woocommerce_customer_completed_order_settings
[gettext_context] =>
[domain_name_context_md5] => 9fce0aecae80d0fcead2d1a2a63d597d
[name] => [woocommerce_customer_completed_order_settings]subject
[value] => Your {site_title} order from {order_date} has shipped!
[status] => 0
[translation_priority] => optional
[allow_empty_value] => 1
)

August 17, 2018 at 3:44 pm #2653705

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

This is a known issue. Please visit this link where you will find more information about this error: https://wpml.org/errata/duplicate-entry-for-key-uc_domain_name_context_md5/

Kind regards,
Carlos

August 17, 2018 at 8:47 pm #2654659

anthony pezzullo

Thanks Carlos,

I'll look into that fix.

I still havent found a solution to the string translation causing the latency when adding products to cart.

I applied a fix to the previous issue you stated but those 403 errors werent causing the issue as when the plugin is disabled the adding a product to cart takes only 2-3seconds max.

If you login to my site and disable the string translation youll notice a big difference oppose to when its enabled.

August 19, 2018 at 4:02 pm #2657409

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Before I continue I kindly as you to create a full backup of the site for security reasons. I won't be making significant changes in the site but as this site is already throwing errors and has several plugins installed the possibility of getting a fatal error is higher.

Please let me know when the full backup of done.
Best regards,
Carlos

August 19, 2018 at 9:35 pm #2657692

anthony pezzullo

Ok Carlos!

The site is cloned and database backed up.

Thanks again

August 20, 2018 at 4:34 pm #2660243

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for creating the copy of the site.

I have applied various troubleshooting steps to the site and now it seems to be faster.

However I suspect th cause of the issue might be a compatibility problem with a third party plugin/theme. I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Deactivate all the plugins that are not related to WPML.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Best regards,
Carlos

August 20, 2018 at 9:19 pm #2661053

anthony pezzullo

Ok,

After much testing I found when i disable the FedEx shipping plugin the add a product to cart causes further delay.

Interesting enough when both plugins ared disabled(fedex & string translation) the add a product to cart is almost seamless & and in most cases under 2 seconds.

When both plugins are enabled this latency jumps between 6-13 seconds.

If you want to play around on my test site and see please visit

hidden link

it is the same credentials as the live site.

August 20, 2018 at 10:19 pm #2661098

anthony pezzullo

Sorry I meant when the fedex shipping plugin is disabled the latency is reduced opposed to when enabled.

but when both the fedex plugin and the string translation enabled the latency increases

August 21, 2018 at 12:43 am #2661234

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that you found the cause of the issue!

Could you tell me if this is the same plugin you have installed in the site? https://wpml.org/documentation/plugins-compatibility/?wpv_view_count=119945&dev=0&wpv_post_search=FedEx+&wpv_filter_submit=Search

Regards,
Carlos

August 21, 2018 at 12:50 am #2661236

anthony pezzullo

Hi Carlos! The FedEx plugin I use was developed by Woocommerce. Here is the link: https://woocommerce.com/products/fedex-shipping-module/

August 21, 2018 at 1:11 pm #2663245

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Thank you very much for this clarification.

I would like to ask your authorization to make a copy of the site to try to reproduce the issue in a local environment.

Looking forward to your answer.
Best regards,
Carlos

August 21, 2018 at 3:47 pm #2663833

anthony pezzullo

sure its no problem!