This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I would like to center this shortcode on my homepage:

[wpml_language_selector_widget]

But it stays always on the left.

Solution:
You can fix this issue by adding the following CSS in your theme’s or child theme style.css file OR Custom CSS section of the theme:

.wpml-ls-legacy-list-horizontal {
	text-align:center;
}

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by gabrielM 5 months, 1 week ago.

Assigned support staff: Noman.

Author Posts
April 23, 2019 at 12:02 pm #3663665

gabrielM

Hello,

I would like to centered this short code on my home page :

[wpml_language_selector_widget]

but its stay always on the left..

Can you help me ?

thank you.

April 23, 2019 at 12:27 pm #3663819

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please provide m page URL/screenshot where I can see this issue.

Also, please add the debug report in the Debug Information box. I have also enabled debug info box for your next reply: https://wpml.org/faq/provide-debug-information-faster-support/

Thank you

April 30, 2019 at 7:59 am #3708917

gabrielM

Hello,

You can see the issu here : :

hidden link

Under the slider, the flag are not centered.

Thank you for your help.

Gabriel

April 30, 2019 at 8:42 am #3709555

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for more details. You can fix this issue by adding the following CSS in your theme’s or child theme style.css file OR Custom CSS section of the theme:

.wpml-ls-legacy-list-horizontal {
	text-align:center;
}

And it will look as in the attached screenshot.

Thank you

May 6, 2019 at 7:27 am #3745425

gabrielM

My issue is resolved now. Thank you!