This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by lydiaC-3 4 months, 4 weeks ago.

Assigned support staff: Dennis.

Author Posts
May 15, 2019 at 2:21 am

lydiaC-3

I am trying to: Translate the Checkout Page

Link to a page where the issue can be seen: hidden link

I expected to see: All Text Translated

Instead, I got: Certain phrases like Email Address are not translated and I cannot find them in String Translation Page?

I found some such as First Name etc. But many were missing

Also some of my translations were in the wrong language Showing up as Chinese (Traditional) when it should be English? But I cannot set the language as Traditional only Simplified which isn't actually on my website

May 15, 2019 at 7:21 am #3813035

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Welcome to WPML Support forum.

Could you please increase the WP Memory Limit (your current setting is 40M). Minimum requirements are 128Mb:

https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

- Add it above the line

 /* That's all, stop editing! Happy blogging. */ 

Also, I would like to recommend you to increase your max input vars, currently it has a value of 1000 in your WordPress Dashboard > WPML > Support section.
Please, try to increase it to 5000. You might need some assistance from your host to properly set this up.

See:
hidden link
hidden link

Then,

-go to WPML > Theme and plugins localization. Be sure that 'Translate themes and plugins using WPML's String Translation only (don't load .mo files)' is selected.
-under Strings in the plugins section, select Woocommerce plugin.
-click 'Scan selected plugins for strings'
-go to WPML > String Translation
-find and translate the string. check 'translation is complete' . click 'save'

Please let me know how it goes.

Kind regards,
Dennis

May 16, 2019 at 1:35 am #3820775

lydiaC-3

Hi Dennis,
I carried out the first 2 steps with my host provider.
When I got to
"-click 'Scan selected plugins for strings'"
I clicked the button and it just sat on the Scanning Now page for 3 hours with nothing evidently happening. Is there a cause for this?

Cheers,
Tym

Update:
It is the String Translations which are an issue as you can see on this page
hidden link
Certain strings are not translated and I cannot find them in translation page (and some are translated the wrong way - showing Chinese on the English page)

May 16, 2019 at 7:21 am #3822559

lydiaC-3

I'm having the same issue as this person
https://wpml.org/forums/topic/dont-translate-some-fields-of-custom-fields-woocommerce-checkout-page-plugin/

But I followed their walk through and I still seem to be running into issues. Hope you can help me.

May 16, 2019 at 7:55 am #3822813

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

I checked your setting in WPML > Support and it seems that the the WP memory limit and max input vars were not yet increased.
Please see attached image

Please note that the wp memory limit code should be inserted before the code

/* That's all, stop editing! Happy blogging. */

Kind regards,
Dennis

May 21, 2019 at 1:43 am #3850815

lydiaC-3

My issue is resolved now. Thank you!