This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Noman 5 months ago.

Assigned support staff: Noman.

Author Posts
December 18, 2018 at 10:24 am #3011609

איילה הלוי

Hi,
How can i change appearance of language switcher? i need it to be round icons with white text color and red bg #FF4438 - same as menu color. in attachment is what i have at the moment.
Please help as fast as you can.

Screenshot here: hidden link

thanks!
Raz

December 18, 2018 at 10:27 am #3011625

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Yes sure I will be more than happy to help you in doing this. Can you share with me a mockup or some design so I can see what exactly you need for language switcher design? That will make it easy for me to understand and provide you with the CSS for it. Please let me know.

And I cannot see language switcher in the menu on this page, can you please add language switcher then I can style it: hidden link

Thank you

December 18, 2018 at 12:38 pm #3012103

איילה הלוי

Hi,
1. Attached is a language switcher image for demo- i hope it will help you to understand what i need.
2. the problem is that i add language switcher to page but i cant see it! I ONLY SEE THIS WHITE RECTANGL like in attchment A.PNG
3. I dont have all content possibility to translate my page - only part of content like title but not paragrafh
4. I cant see translated page
PLEASE HELP

December 18, 2018 at 4:59 pm #3013224

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

December 19, 2018 at 3:58 pm #3017388

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have logged in to your site and checked theme/plugin conflict in your site. The issue is gone when I deactivated Bruno theme and activated wp default theme e.g. twentyseventeen as you can see in attached screenshot.

Also I couldn’t find Bruno theme in our verified compatibility theme list:
https://wpml.org/documentation/theme-compatibility/

I recommend to please ask Bruno theme author so they can advise you on latest compatibility of their theme and WPML, may be they have fix for it, so it should work fine with wpml.

If you want me to fix this issue then I’ll need to have your site FTP. I have enabled private input box for your next reply.

Thank you

December 24, 2018 at 8:02 am #3029897

איילה הלוי

Hi,

Yes, I'll be happy if you can fix this issue!
PLEASE, attached is demo to language switcher style i would like to have in my site.

Here is my site FTP:

[FTP_REMOVED]

THANK YOU AND PLEASE UPDATE ME AS SOON AS YOU CAN.

December 24, 2018 at 10:19 am #3030172

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

FTP login info that you have provided is not working here as you can see in attached screenshot. Could you please provide me correct FTP login please. I have enabled private input box for your next reply.

Please note that I edited your topic because you had posted sensitive information (FTP login info) in a public forum.

Thank you

December 24, 2018 at 10:49 am #3030260

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

No sorry, its not working. It says user or password is incorrect.

December 24, 2018 at 11:18 am #3030337

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Yes its working now, thanks

December 24, 2018 at 1:45 pm #3030584

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

1. I have fixed this issue by adding below code:

<div class="custom-lang-switcher">
	<?php do_action('wpml_add_language_selector');?>
</div>

==> in wp-content/themes/dpr-bruno/layouts/main-nav.php file and line no. 21

Backup file exist in same directory with name ‘main-nav.php-backup-original’

2. And added following CSS in Appearance >> Customize >> Additional CSS section of your theme.

.wpml-ls-legacy-list-horizontal {
	padding:0;
}

.custom-lang-switcher {
    text-align: right;
	
		
}

.wpml-ls-legacy-list-horizontal a {
	background:#fff;
	border-radius:50px;
    	color: #000;
	font-size:10px;
	font-weight:bold;
	width:25px;
	height:25px;
	line-height:23px;
	text-align:center;
	padding:0;
	display:inline-block;
	margin-right:5px;
}

-- You can ask theme author to update this value in future versions as this change will be overwritten when you update DPR Bruno theme.

Please check and confirm the fix.

Here is doc for more details:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/#custom-locations

Thank you

The topic ‘[Closed] Change appearance of language switcher’ is closed to new replies.