This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by galinaS-3 2 months, 2 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 19, 2019 at 12:37 pm #4246489

galinaS-3

How do I change current menu translations and footer translations?

July 19, 2019 at 10:24 pm #4248459

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I am not sure that I know how the current translations were created so I would first like to take a look in the backend so that I can give you more precise guidance than just a general one.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

July 23, 2019 at 3:31 pm #4267433

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I am glad to hear that the issues you reported above were resolved.

Regarding the contact form 7 translation, can you please let me know if you had the chance to follow the steps from the documentation link below?
https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/

Please let me know how that goes.

Kind regards,
Mihai

July 24, 2019 at 12:05 pm #4274273

galinaS-3

I am trying to do the steps but it does not show 'contact form' only 'sign up form' and footer form... see screen shot attached ...?????

July 24, 2019 at 3:28 pm #4276097

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I was not able to find the "Contact Form 7 Multilingual add-on" plugin installed on the site so that might be the reason (https://wpml.org/documentation/plugins-compatibility/using-contact-form-7-with-wpml/#what-you-will-need).

You should be able to download that plugin from wpml.org account and then install it.

Please let me know if this solved your issue or if you still need help.

I will be waiting for your response.

Kind regards,
Mihai

July 26, 2019 at 8:37 am #4288381

galinaS-3

I have downloaded the plugin. But still not quite sure how to get the translations to work? See screen shots. When I click on the little cog to edit then I get this 'not found' page... Please advise.

July 26, 2019 at 3:04 pm #4290303

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

From what I can see, it seems that one of the forms has the gear icons and the other one has the circle arrows icon which means none of the two is currently published.

Please try this:

1. create a full backup of the site
2. disable all the non-WPML plugins (leave contact form enabled, too)
3. then click on one of the engine icons (i hope that you won't be getting the not found error anymore), make sure that you finish the translation and then publish it.

See if the form translation is working now in that language.

Let me know how that goes and if it solved the issue.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

August 9, 2019 at 1:37 pm #4370827

galinaS-3

Hello, sorry I have been on holiday. I have tried to follow your steps but still having a lot of issues. Now the contact form shows as translated but looks like this...how do I undo????? And I can't find translations for Swedish and German, please help.

August 9, 2019 at 1:39 pm #4370881

galinaS-3

I have deactivated the multilingual plugin for the time being (until you get back to me)...as the contact form kind of disappeared.