This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 5.76 hours from now. Thank you for your understanding.

This topic contains 2 replies, has 2 voices.

Last updated by oscarM-16 1 month ago.

Assigned support staff: Noman.

Author Posts
September 12, 2019 at 8:58 am #4559585

oscarM-16

Tell us what you are trying to do? I want to enter a new text for the default language string

Is there any documentation that you are following?

Is there a similar example that we can see?

What is the link to your site? hidden link

September 12, 2019 at 2:14 pm #4561633

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

1. If you want to change the default language texts/string, you must edit the strings directly in the file of your theme/plugin. you must edit the strings directly in the file of your theme/plugin.
After edit that string, you need to scan your theme/plugin again.
To do this, first edit the strings in the necessary files. Then click on the WPML >> Theme and plugins localization. Make sure the option "Translate the theme and plugins using WPML's String Translation" is selected.
Scroll down and look at the "Strings in the theme". Click on the "Scan the theme for strings" button.
If the strings are in the plugin, scroll down, and look for "Strings in the plugins". Select the correct plugin and at the end of the page, click on the "Scan the selected plugins for strings" button.
Then again in WPML >> String Translation, you can translate the new string.

Or

2. You can try this workaround:
- Go to WPML >> String Translation and find the string you want to edit in the default language.
- Select it and click on "change selected strings language" option from the dropdown and change the language to any "dummy" language.
- Now you should be able to see the option to "translate" it in the original language.

Thank you

September 16, 2019 at 6:44 am #4576615

oscarM-16

My issue is resolved now. Thank you!