Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by nimoB 1 year, 4 months ago.

Assigned support staff: Bruno.

Author Posts
May 30, 2019 at 5:52 pm #3925481

nimoB

My SEO specialist advised me, to change the URL Format of the existing second language , f.e., hidden link,
to
hidden link

It's supposed better to index the site in the second language

I made the change by in Language URL format to change this.
Different languages in directories ((hidden link - English, hidden link - German))

Now, after change, The "home " page in German is not accessible anymore.
All other pages work in both languages and menu links are correct.
German Menu "Home" always goes to "English "home", although permalink german "home " is set as " hidden link"

can you give advice?

____________________________________________
I edited your message. Please do not disclose your username and password in an open forum.

May 30, 2019 at 11:33 pm #3926567

Bruno

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

For me both pages work correctly:

EN: hidden link
DE: hidden link

On the secondary language page, however, the slider was not created in the Slider Revolution but the page is opening normally.

If this is not what you are asking, can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

May 31, 2019 at 7:06 am #3928229

nimoB

thanks, i could solve meanwhile almost all problems myself (as you have seen)

There is only one issue left:
The menu "shop" goes to opencart, outside of WP.
The link from second language since changing the URL name by WPML to the shop is broken, and i cannot find the reason.
In first language it works.

May 31, 2019 at 11:05 pm #3933585

Bruno

Glad to hear that it now works. From what I noticed you have two shops page inserted on your site.

In Pages > All Pages, you can see the "Shop" page and the "Shop" page is translated. You should probably have a directory called "shop" inside your server, where OpenShop should be installed.

The default is that WordPress first loads directories and then pages. That is, as the "shop" directory exists, the "shop" page is ignored. In the secondary language, however, the page created in WordPress is being loaded instead of the "shop" directory.

You have two options that you can test:

- Redirect URL from /de/shop to /shop/ using the Yoast SEO redirects feature;
- Removing both "shop" pages and creating a custom menu item with a custom link. That way you could add two equal links in both languages. You can see the WordPress documentation: https://codex.wordpress.org/WordPress_Menu_User_Guide. I'll attach an image for you to see.

Thank you.

June 3, 2019 at 6:56 am #3939665

nimoB

My issue is resolved now. Thank you!