This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I bought the WPML lifetime membership and I can't change the former expired registration on my site.

Solution: https://wpml.org/forums/topic/change-of-registration/#post-4267969

This topic contains 4 replies, has 2 voices.

Last updated by expat 2 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 23, 2019 at 2:56 pm #4267205

expat

Hi got lifetime trying to change a former expired registration.
It does accept the key - shows lifetime - but the plugins still do not like it showing reg expired .....
Yes the site is on 4.7 and I want to upgrade to 4.9.10

Q: Upgrade WP and then retry wpml? ...
Thanks
Martin

July 23, 2019 at 4:18 pm #4267969

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Martin and thank you for contacting WPML Support!

I will be happy to help you with this.

My recommendation is that you first create a full backup of the site and then that you manually update the WPML plugins by following the steps below:

  • download the latest version of WPML (and the other WPML plugins that you are using and want to update) from https://wpml.org/account/downloads/;
  • disable WPML Multilingual CMS
  • delete WPML Multilingual CMS (the settings and the translations are saved in the database so they will not be deleted);
  • upload the freshly downloaded WPML plugin from Plugins → Add New → Upload Plugin
    → Activate WPML
    ;

Please let me know if this solves the issue or if you need further details.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 24, 2019 at 12:39 pm #4274383

expat

Hi
deactivated - deleted on server - uploaded latest version still same problem... see pics.
Hoped to avoid this in future as I m on mobile hotspot due to failing internet here in rural galicia.....
Cheers
Martin

July 24, 2019 at 12:55 pm #4274691

expat

Hi
sorry - it worked - forgot to upload some root content of plugins.
I have closed this now.
Martin

July 24, 2019 at 12:56 pm #4274699

expat

My issue is resolved now. Thank you!