This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by d.K 11 months, 3 weeks ago.

Assigned support staff: Yvette.

Author Posts
October 11, 2018 at 7:19 am #2806902

d.K

I have opened a ticket about this subject months ago and have been told that this will be solved in an update: Ricardo Alday helped me as far as he could. But we had to wait for the update. I think we are ahead of the update now. So I posted the following message (but this ticket was closed already) See attached printscreen of the previous ticket. Would it be possible to inform me how to change photo's in the product page now. (unlock the existing photo's)

Dear Ricardo,

I just checked the version of WPML and I found that we have already passed version 4.0.1
Is it possible to remove the locks from the photo's in the product pages already for the different languages? Thanks a lot for your answer.

Best regards,
Dieke

October 11, 2018 at 3:50 pm #2809041

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I tried to find the old ticket you referenced, but I don´t seem to be able to find it. If you could include the link, this would be great.

In general, with the way that WPML Media Translation is currently working, you are able to change the image that is shown in each language for a product using the Media Translation module. This is the only way to be able to distinguish images by langauge.

If you do not need to have either a different image or any language-senstive texts, then you can bypass the Mediat Translation modules and simply duplicate the media via WPML -> Settings -> Media Tranaslation.

I am not sure if I have well understood your original issue and what you mean about the lock on the photos, so if you can please include a screenshot and an example from your site, then I can help you more.

I am also opening the private area for you to provide system access details in case I need to investigate this further.
Thanks

October 12, 2018 at 10:22 am #2811582

d.K

https://wpml.org/forums/topic/change-media-per-language-for-products-in-product-gallery/

This is the link. Hope you understand my question. If not please let me know.

Br Dieke

October 12, 2018 at 11:45 am #2811781

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

OK - yes I understand more.

Would you mind if I looked at this on your site?
I am opening the private area for this. Please provide a sample product I can look at as well.

Thanks

October 16, 2018 at 10:09 am #2820494

d.K

How would you like to do this Yvette? Do you mean you would like to logg in at my website to check this?
Br Dieke

October 16, 2018 at 10:51 am #2820646

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Yes - that is what I mean,. I have opened the private area for access data (wp-admin and ftp)

Don`t forget to include clear steps to replicate the issue with a sample test case on your site.

Thanks

October 16, 2018 at 4:01 pm #2821690

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

So, with the new Media Translation plugin, you have the possibility to associate a different image with a specific language.

While the gallery still has the lock - you can change the image it shows by using Media Tranlsation (see images).

What still cannot be done is have a different number of images showing in each language.
So, it is technically in this manner but the product gallery image is still locked.

Does this answer your quesiton?

October 29, 2018 at 9:44 am #2857272

d.K

Hi Yvette, Thanks for the feedback. I tried this at my website. But the photo's I translated does not change on my website. Please see print screens for more info. The language is still in Dutch......

Another thing happens. When I opened another photo to start translating the photo zoomed and I could not add any info.... Very strange. Is there a bug or something in this system? I tried some other photo's but they all have this problem.

October 29, 2018 at 2:21 pm #2858357

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Image Translation
I am having trouble understanding this. I visited this image from your media library:
hidden link
When I select to change the English I see just what is translated by Media Translation:
hidden link

I then tried to find where this particular image was attached as a product image and I could not find any easily where it also displayed text. So, could you please send steps to replicate the error you are seeing?

2. Enlarged image
I see that this is only happening with a subset of images and not all images. It seems like it is with images where you have uploaded an alternate image.

Could you try installing the plugin "Regenerate thumbnails"
https://wordpress.org/plugins/regenerate-thumbnails/

I am suspecting that the new image is missing the thumbnail.

October 30, 2018 at 1:11 pm #2861868

d.K

My issue is resolved now. Thank you!