This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Bobby 3 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
June 18, 2019 at 12:20 pm #4043739

jaapd-2

Hi,

I want to change the product url to this:

Dutch: hidden link
English: hidden link

But I'm not able to change it. The url keeps pointing to hidden link

How can I change the "product" part to "yogakleding"?

I've set the product permalink to /yogakleding/%product_cat%/ and translated the strings.

When I disable WPML it's working fine.

June 18, 2019 at 5:49 pm #4045573

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

i was able to perform this change as expected on my testing enviroment.

to do this i did the following.

1. Go to WP->Settings->Permalinks-> product custom base and add "yogakleding/%product_cat%"

2. Test your products , are you able to see this permalink structure in all languages ? if yes move on to the next step

3. Go to WPML->Settings -> Post Types Translations->Products and set different slugs for each language

let me know your results please

June 19, 2019 at 11:33 am #4051125

jaapd-2

Hi,

I managed to fix some issues. The only thing not working are the product category links. When I try to visit one I receive a 404.

You can also test it on: hidden link

Please help.

Cheers,
Jaap

June 19, 2019 at 5:45 pm #4053621

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Jaap,

are you still experiencing the 404 issue ? when i visit them i was able to see the products as expected

June 19, 2019 at 5:57 pm #4053739

jaapd-2

Hi Bobby,

I had to change back the slug to product-categorie since it is a production webshop.

Shall I give you access to the staging website?

Cheers,
Jaap

June 19, 2019 at 6:17 pm #4053833

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

So does it work as expected on the production site ?

i have enabled the private field reply in order to share with me access to the staging site

June 20, 2019 at 8:51 pm #4063007

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the access details !

if possible please verify the details as i am not able to access the backend

June 20, 2019 at 8:56 pm #4063043

jaapd-2

Can you try again? Same credentials

June 20, 2019 at 9:25 pm #4063149

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please review

hidden link

and the English one , notice yogakleding and yoga-wear is correctly used now

hidden link

also the product categories show as expected as well now

hidden link

This was being caused due to the product_category being translated to yogakleding switching it back to product-category resolves the issue

June 21, 2019 at 6:30 am #4064921

jaapd-2

Hi Bobby,

Thanks but that's not how I want it. I want the product category urls to include the shop slug instead of the product-category slug. So: hidden link and in English: hidden link

The product urls are correct. They have the shop slug inluded: hidden link

Is this possible?

Cheers,
Jaap

June 21, 2019 at 4:54 pm #4068611

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Jaap,

this seems to be more of a WordPress/Woo-commerce issue rather than caused by WPML

i have test this on a clean environment without WPML installed and got the same results, the product-category when set to the product base causes a 404

you might be able to achieve your desired structure with some custom work for example the following forum thread
=> https://stackoverflow.com/questions/28221920/woocommerce-change-product-category-slug-to-shop-base