Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by brigitteK-2 9 months, 4 weeks ago.

Assigned support staff: Marcos Vinicios Barreto.

Author Posts
March 27, 2019 at 9:25 pm #3475813

brigitteK-2

Hello again

I have one more question:
- The base language of my shop is English.
- I use articles with variation (different sizes)
- Underneath every article there is a button that says: "select option", which is not accurate. You might want to look: hidden link

The same goes for the text in the dropdown menu. I also would like to change this as I did in German and French. hidden link

Is this possible?. Thanks a lot and kind regards, Brigitte

March 28, 2019 at 1:23 am #3476375

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for contacting WPML Support. It seems your theme has some customized WooCommerce template to display your product categories pages and it this case you would need to overwrite the text in the default language. I would like to give a further look here in order to provide you with a detailed and accurate answer. For that, please, consider:

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

March 28, 2019 at 8:24 pm #3485509

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the provided details. Regarding your requests:

Changing the strings in the default language.

WPML helps you translated your default strings to a secondary language, if you wish to edit the main language you are techincally changing the original hardcoded strings which should be done within the code and that is why WPML does not offer this function as of now. However, there's a workaround for that:

1 - In your WordPress Dashboard > WPML -> Languages add a new language, scroll down and hide the language (can be any language).

2 - Go to WordPress Dashboard > WPML > String Translation and find the string you want to edit.

3 - Select it and click on 'change selected strings language' and change the language to the new 'dummy' language we just added.

4 - Now you should be able to see the option to 'translate' it in the orginal language (english in your case) therefore allowing you to edit the default string without having to mess with the code.

See: https://wpml.org/documentation/getting-started-guide/string-translation/

Disabling the 'Multilingual WordPress with WPML' text.

1 - In your WordPress Dashboard > WPML > Languages uncheck the option 'Tell the world your site is running multilingual with WPML (places a message in your site's footer)' under the WPML Love settings.

Please, let me know if you need any additional clarification, have a nice day.

March 29, 2019 at 8:07 am #3488681

brigitteK-2

Hi Marcos, thank you very much.
1. I chose Hungarian as a "dummy" language and hid it.
2. "Change the language of selected strings"
3. As you said I could change the English version. Done and saved.
4. It just does not show on the buttons in the shop. hidden link

Did I forget or misunderstand something?

Thanks again and have a happy Friday. Brigitte

March 29, 2019 at 2:58 pm #3492429

Marcos Vinicios Barreto
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Bahia (GMT-03:00)

Hello,

Thank you for the updates. Sorry I could confirm this method is indeed not working, I found it in our tickets database. In this case, the only working option we have for now is editing the theme files to change the default string right in the theme template files. It is recommended a basic theme development knowledge and the use of the child theme approach to avoid to loose these changes in case of theme updates.

See: https://codex.wordpress.org/Child_Themes

Sorry for not being so helpful this time. Have a nice day.

March 29, 2019 at 3:45 pm #3492691

brigitteK-2

It is not fully solved but it is also ok. Thank you!