This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by catarinaP 1 month, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
August 8, 2019 at 9:43 am #4361525

catarinaP

I'm trying to change the website URL from hidden link to the site that I registered my WPML account (magnumcap.com/SITE2019), but I can't do the migration or any changes. What can i do? Thanks

August 8, 2019 at 3:09 pm #4364127

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

From my understanding, you had a local environment and now you are trying to migrate it to a live environment.

My recommendation is that you use a plugin like "Duplicator" to migrate your site to the live environment:
- https://wordpress.org/plugins/duplicator/

Documentation can be found here:
hidden link

Here is a small tutorial on how to use Duplicator:
hidden link

Practically you will have to create a full backup of the current site (create a Duplicator package) and then copy the files (you will have an archive file + an installer.php file) and put them inside the "SITE2019" folder on your server.

I hope that you will find this information helpful.

Please let me know how it goes and if you have any other questions regarding this topic.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 9, 2019 at 8:59 am #4368829

catarinaP

The sites are different, so I can't use duplicator, it will overwrite the site I want to maintain, the "SITE2019" one. It's not a website migration question. It's just the URL in the AMS Panel that is wrong and not corresponds to the site registered in the WPML account.
This way, the API can't communicate between AMS and WPML and doesn't allow me to sync translator and translation managers (like the image shows).
Thanks!

August 9, 2019 at 3:34 pm #4371647

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sorry, I did not realize that we are talking about 2 separate websites, I thought that it's just 2 separate domains (the localhost address and the live domain address).

In this case, you should be able to go to the WordPress panel > Plugins > Add new > Commercial > unregister the current link to WPML and register it with a new key for the right domain.

Please let me know if this is what you mean.

If not, is there any chance you can create a screen recording or any video/screenshots explaining a bit more what you are exactly trying to accomplish?

I will be waiting for your response.

PS: Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

If you would prefer to not wait for a ticket response, you can mark this current ticket as resolved and in the process of creating a new ticket, you can select the "Live chat" option (it should be the default method now).

Kind regards,
Mihai

August 12, 2019 at 10:33 am #4380077

catarinaP

I think this is exactly the same problem as mine : https://wpml.org/forums/topic/change-or-add-website-url-on-ams-panel/?fbclid=IwAR2iAXhHNbRjjEySZ5DbdmWZWS40S5RwfBG1I_TEnlnPJgiV6YjhqoCbBEg

August 12, 2019 at 4:28 pm #4382325

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I wrote to one of my colleagues that were involved in that ticket and I will get back to you as soon as I get an answer.

I will leave the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 14, 2019 at 8:02 pm #4397301

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

I wanted to keep you updated about this.

I forwarded this issue to another developer from our team as the other one is not available currently.

I will get a response tomorrow.

I will keep you updated.

I am leaving the ticket assigned to myself for the moment.

Kind regards,
Mihai

August 15, 2019 at 10:09 am #4400177

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

So I got in touch with a developer of ours and he asked for site credentials.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

August 20, 2019 at 12:22 pm #4423495

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

We made a small update in the database to solve this issue.

I am also attaching a screenshot.

Please let me know if the issue is showing as resolved on your side, too.

Kind regards,
Mihai Apetrei

August 21, 2019 at 8:12 am #4428943

catarinaP

Thank youuuu! 🙂