This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 19, 2018 at 7:44 pm #2749872

Dimitris Chatzimanolis

Hi,

I would like to ask you if it's possible to have the same language switcher appearance at my client's website hidden link, where I use WPML for multilingual content as the reference website below:

hidden link

Could you please give me some advice on how could I achieve that?

Thank you in advance!

September 20, 2018 at 7:43 pm #2753189

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

Thank you for contacting us. Yes, you can configure the language menu by following the steps below:

- Click on the WPML > Languages > Site Languages
- Click on the "Edit Languages" link
- On the language names, just add codes. For example, EN to English, GR to Greek, etc
- Click on the Save button
- Click on the WPML > Languages > Menu language switcher
- Click to edit the menu
- On the "Language menu items style", select the "List of languages" option
- On the "What to include in the language switcher", select:
-- Native language name
-- Current language
- Click on the Save button
- On the WPML > Languages > Language switcher options
- Click on the "Additional CSS" and insert these lines:

li.wpml-ls-item:last-child:before {
    content: '\f0ac';
    font-family: fontawesome;
    font-size: 20px;
    position: absolute;
    left: -55px;
    top: 7px;
}

li.wpml-ls-item a {
    padding: 5px !important;
    margin-left: 25px;
}

li.wpml-ls-item:last-child a {
    margin: 0;
}

Please, let me know if I can help with any other questions you may have. I'll be happy to help.

Thank you.

September 21, 2018 at 4:46 pm #2756036

Dimitris Chatzimanolis

Hi,

Thank you for your reply!

While installing WPML on my site, I get the following message:

ICL_DONT_LOAD_LANGUAGE_SELECTOR_CSS is defined in your theme. The language switcher can only be customized using the theme's CSS.

I tried to add your recommended CSS at the additional CSS field of WPML to have my own language switcher but it seems like it doesn't load it. How is it possible to load the above CSS?

Waiting for your advice.

September 22, 2018 at 12:16 am #2756654

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. This message you posted shows that your theme is not loading the WPML CSS. This, however, should not affect the CSS I posted above. If you are using any cache plugin, have you tried clearing the cache?

As your theme is not loading the WPML CSS, it should be for some reason - maybe the author of your theme has done the custom CSS and so do not load the WPML CSS.

To be able to look better at your theme, I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please, can I install the Duplicator or All in One Migration plugin to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

September 24, 2018 at 7:46 pm #2761688

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. In addition to inserting this code into the "Additional CSS" option, did you insert it into some other options page? I ask this because no changes I make in Additional CSS works.

Also, on the Impreza > Theme Options, the page is not displayed. This appears in white. I'll attach an image for you to see.

Thank you.

The topic ‘[Closed] Change WPML language switcher appearance’ is closed to new replies.