This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I am not able to connect a translated page to an original page.

Solution: I found that in the icl_translations table, your French page already had a connection, but it was connected to a post with the element_id set to null. Once I removed this connection, I was able to see the link "connect with translations". I also removed a null translation for Spanish and Italian. This likely means that the page was previously connected to a page that was sent to the trash, but perhaps not completely deleted, or a page that was set to draft.

This topic contains 13 replies, has 3 voices.

Last updated by Ron 1 month, 1 week ago.

Assigned support staff: Lauren.

Author Posts
August 22, 2019 at 11:01 pm #4443107

Ron

Tell us what you are trying to do?

I have an existing translated page that I wish to change the translation redirect to a different page than the current one.

I am not sure how to do that.

August 23, 2019 at 4:24 am #4444111

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

If i understand correct you have a page in the default language that has been translated to Spanish for example.

but now you want people to instead of going to that page's Spanish translation to be redirected to a different page on the site or off the site , correct ?

WPML at the moment does not offer such feature but you might be able to achieve this with a redirect either custom or through a 3rd party plugin.

August 23, 2019 at 3:33 pm #4448481

Ron

Bobby,

Maybe I was not clear enough. I used the WPML to connect hidden link to hidden link

I wish to change the connection to hidden link

August 23, 2019 at 7:49 pm #4449647

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Thank you for the clarification ,

in your screenshot where it says "This is a translation of ..." click the dropdown and select "none"

this should disconnect the 2 pages allowing you to re connect the page with another translation if you wish

let me know your results

August 23, 2019 at 10:26 pm #4449949

Ron

Thank you for the last message. Now I am faced with no option to link to an existing translated page. What am I missing?

August 24, 2019 at 8:00 am #4451043

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Your default language is English, therefore you should only see the option to
"link with translations" within English pages

the language of the page you are looking at the moment is French so that option to link with translations wont be available

If my above instructions do not help to point you to the correct direction please let me know which page you are trying to connect and i can access your backend to take a closer look

August 24, 2019 at 3:14 pm #4451995

Ron

There does not appear to be that option on any of the English pages.

hidden link is one example

August 26, 2019 at 7:48 pm #4461087

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Hi there, Bobby is off for a few days. Would it be possible for me to login to your site and take a look at some WPML settings?

/I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

August 28, 2019 at 2:18 am #4470413

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for sending credentials. I would like to test something, but wanted to check with you first. If you disconnect the German translation, do you see the option to connect the original page with translations? I am wondering if the link is not showing because there is a translation in one of your languages.

If this is the case, we may be able to edit the database to link the translations by adjusting the Translation ID for the pages. Is it okay if I install the Adminer plugin to check the Translation IDs?

August 28, 2019 at 3:08 pm #4475357

Ron

Please do

August 28, 2019 at 8:00 pm #4476733

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for allowing me to test that. I found that in the icl_translations table, your French page already had a connection, but it was connected to a post with the element_id set to null. Once I removed this connection, I was able to see the link "connect with translations". I also removed a null translation for Spanish and Italian. This likely means that the page was previously connected to a page that was sent to the trash, but perhaps not completely deleted, or a page that was set to draft. I'm not 100% sure how the element_id= null was created, but regardless, you are now able to connect the About page to other languages. I connected it to French already.

Please let me know if you need any further assistance and I will be happy to help.

August 28, 2019 at 10:16 pm #4476977

Ron

Thanks! As we go through the site, is there a way from me to fix other pages if the element_ID is null or there is no translation option?

August 28, 2019 at 10:32 pm #4476993

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Yes, if you find a page that doesn't have the option for translation, look in the database in the icl_languages table. You can search by the element_id (which you can find in the URL when you are editing the post). Once you find that, you will see the associated TRID. Then, search the same table for that TRID and you will see any pages/posts connected. If the element_id is set to null, you can delete that row from the table.

I hope this helps!

September 4, 2019 at 11:20 pm #4514261

Ron

Hi. I hope this thread is not closed yet. This solution seems to be a very time consuming and technical process to fix the pages that do not have the option to connect to an existing translation.

There must be a better way