Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: Change the color for the font for the active language in the WPML Language Switcher.

Solution: Solution here: https://wpml.org/forums/topic/changing-color-font-for-active-color/#post-2527616

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by victor tio 3 years, 6 months ago.

Assigned support staff: Noman.

Author Posts
July 9, 2018 at 3:31 am #2474714

victor tio

Tell us what you are trying to do? change the color for the font for the active

Is there any documentation that you are following? just the setting in wpml settings for language switcher

Is there a similar example that we can see? no, that i know of

What is the link to your site? hidden link

Screen_Shot_2018_07_08_at_10.57.39_PM.png
Screen_Shot_2018_07_08_at_10.57.57_PM.png
July 9, 2018 at 2:12 pm #2476653

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Victor tio,

Thank you for contacting WPML support. I can not access the home page because the site is in Coming Soon state. You can use following CSS in your theme’s or child theme’s style.css file:

.wpml-ls-current-language a {
	color: #000 !important;
}

⇒ Please don’t forget to change #000 to your required color for active language.

If above code not working then please disable coming soon state so that I can see the issue and provide you CSS accordingly.

Thank you

July 14, 2018 at 3:47 pm #2497928

victor tio

thank you, sorry for the delay, I added it and assigned the color #ffffff but still the title shows in grey, i disabled the coming soon page you can login now

Screen Shot 2018-07-14 at 11.47.22 AM.png
July 16, 2018 at 7:59 am #2527616

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Victor tio,

You can fix this issue by adding following CSS in your theme’s or child theme css file:

.wpml-ls-current-language > a span {
	color:#fff !important;
}

And it will look as in attached screenshot.

Thank you

active color update.png
July 16, 2018 at 10:41 am #2527909

victor tio

Lovely, thank you!