This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Changing Default Language Doesn't Work

Solution:DNS issue temporarily caused by the company hosting the domain name and outside our control

Relevant Documentation:

This topic contains 11 replies, has 2 voices.

Last updated by kurtF 1 year ago.

Assigned support staff: Bobby.

Author Posts
September 11, 2018 at 6:54 pm

kurtF

I am trying to Change the Default language from EN to FR.

When I try and select FR as the default language and press the 'Save' button, nothing happens. When I refresh the page, EN is again the Default language.

Also deselecting 'Use directory for default language' doesn't work. When I deselect this option and refresh it reverts back to this option.

However, other settings like Hiding a language seem to work fine.

Any suggestions of what can be the issue here?

We basically want to move 1 language (FR) from a multi-lingual site topfanz.be to its own domain topfanz.fr. So I copied the site and want to make FR the default language and after that hide or remove the other languages to complete the process.

Many Txs
K

September 12, 2018 at 2:15 pm #2727864

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i am trying to access your site but i currently cannot due to the warnings being displayed

if possible please go in your wp-config.php file and look for define(‘WP_DEBUG’, true);. Change it to:define('WP_DEBUG', false);

also , are you using a cache plugin , usually SiteGround memcache creates such an issue with adding a default language.

please let me know when debug display is deactivated so i can access the site and take a closer look.

additionally do you have any drop in plugins activated ? i have tried accesing your FTP but the details are not working.

September 12, 2018 at 6:47 pm #2728718

kurtF

Hi Bobby,

Many thanks for looking into this. Disabling the cache plugin (WP Rocket) solved the problem partially. I got further but unless I disable wpml-string-translation (by renaming the directory) I get HTTP Error 500 on all admin pages. Not sure why and tried a few things without luck.

DEBUG mode is now set to false.

In terms of the FTP user name and password, I tried and they seem to work for me. However on FileZilla I had to set FTP transfer mode to 'Active' in settings and 'Only use plain FTP (insecure)' as encryption mode in order to get access.

Txs
K

September 13, 2018 at 8:15 am #2730570

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

if possible i would like to take a closer look as there might be a field missing in the database causing this error 500 as well with String Translation.

the credentials for the backend are not longer granting me access

i have enabled the private field box again

thank you !

September 13, 2018 at 2:48 pm
September 14, 2018 at 7:21 am #2734200

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i have test it , and also had some of my colleagues test it as well and we are not able to establish a connection to the FTP.

at the moment i need to access it to "deactivate" manually wpml string translation as i am trying to test it and see why this is happening.

there were some fields missing in the database which i have now replaced but it looks like we will need to also upgrade the WPML versions as well as they are currently outdated.

September 14, 2018 at 8:49 pm #2736672

kurtF

Hi Bobby,

It's strange that the FTP doesn't work from your end.

Can I send you the /cpanel access instead for the site? That will allow you as well to access the files you need.

Many thanks
Kurt

September 17, 2018 at 10:10 am #2740610

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

yes that could work , i have enable the private field area for your next reply

September 17, 2018 at 1:15 pm
September 17, 2018 at 8:18 pm #2742460

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

please note the error i receive ..

is there maybe another way that you access your cpanel ?

for example i know with godaddy accounts you just go through their site and login.

my IP address is needed is 78.87.161.97

September 17, 2018 at 8:30 pm
September 18, 2018 at 6:56 am #2743724

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

please go in your FTP and navigate to wp-content/plugins/sitepress-mutlilngual-cms/ and add ".deactivate" at the end of the file

this will manually deactivate WPML.

at the moment i am not able to reach your site at all , and i believe this might be the reason.

are you able to access your site ? if yes then i believe my IP might be blocked.

September 19, 2018 at 2:30 pm #2749039

kurtF

Hi. That problem has now been resolved (was DNS issue temporarily caused by the company hosting the domain name and outside our control). The site is back accessible now. Many thanks.

September 21, 2018 at 10:51 am #2755006

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

i am glad to hear the issue has been resolved, to make sure..is the original issue that caused you to open the ticket now resolved along too ?

September 25, 2018 at 1:47 pm #2764027

kurtF

My issue is resolved now. Thank you!