This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by András 1 week, 4 days ago.

Assigned support staff: Yvette.

Author Posts
October 9, 2019 at 1:02 pm

András

I am trying to: Change the default language of the site from Hungarian to English in WPML. After changing the default language, on the site when I switch back to Hungarian, the pages of the products give the 404 error. I also would prefer to set the language URL format into different directories, but I do not know if that messes up further more things.

Link to a page where the issue can be seen: hidden link

I expected to see: The products page in Hungarian as it is working, when the default language in wpml is Hungarian.

Instead, I got: The 404 error

I left now the default language in English, that you can see the problem. You have to switch to Hungarian after opening one of my bicycle tours for example:

hidden link

If you need access to the admin site please let me know.

Thank you,

Best wishes.

András

October 9, 2019 at 5:21 pm #4724879

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

It seems that there is some kind of redirection happening when using "product" as the permalink base.

When I changed the permalink base from "product" to "our-tours" (which is what the system seemed to want to do), you are able to see the HU products.

Do you have an idea where this redirection might be coming from?
Or are you content to keep the product permalink base to be "our-tours"?

Right now, you can view your HU tours.

October 10, 2019 at 7:24 am #4728025

András

Hi Yvette,

Thank you for the help! To be frank, I do not know, anything about the redirection, since it wasn´t me who have built the site. Unfortunately who have built it, also didn´t know...
For me the important thing was, that the default language to be English, and that the whole site could be funcional and visible. Now it is, so this issue seams to be resolved!

Let me ask another question please, a little bit off topic, I would need someone, or a reliable company, who could do the SEO part of this site. Some thing have been done, but I think it is not the way it should be. Do you know someone maybe?

Thank you very much once again!

Best wishes!

October 10, 2019 at 8:28 am #4728383

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

That´s great!

I´ve pinged some people who know about SEO to look at this ticket and perhaps contact you directly.

Apart from that, you can also try the list of contractors here:
https://wpml.org/contractors/

Filter by "SEO".

Kind regards

October 10, 2019 at 8:35 am #4728455

András

Hi Yvette,

Thank you very much yet again! Best wishes, take care!

András

October 10, 2019 at 8:38 am #4728469

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

= )

October 10, 2019 at 8:44 am #4728479

András

My issue is resolved now. Thank you!