Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 2 voices.

Last updated by Mateus Getulio 2 weeks, 3 days ago.

Assigned support staff: Mateus Getulio.

Author Posts
May 12, 2022 at 9:23 am #11206435

Tim

When I go to the product page and want to change certain things like text and image. Jumps the whole page and the page goes out of stock

Schermafbeelding 2022-05-12 om 11.23.01.png
Schermafbeelding 2022-05-12 om 11.21.51.png
May 12, 2022 at 8:28 pm #11211683

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your contact, and welcome to the WPML support forum!

Let's try a possible solution and some debugging steps for this issue. By looking at your debug info, it is possible to see that the WP Memory Limit is set to 40M, while the recommended is 256. Changing it can solve the problem. Please follow these steps:

- Find your wp-config.php file in the root directory of your WordPress installation
- Open the wp-config.php file with a text editor, then locate the line that includes: define('WP_DEBUG', false)
- Then add after it, the below line of code: define ('WP_MEMORY_LIMIT', '256M');
- Save the wp-config.php file, then refresh your website and check if the issue persists

If the problem remains, we might be facing an interaction issue with a third-party functionality, in this case:

- Deactivate all the plugins that are not related to WPML
- Switch for a moment to a WordPress default theme like Twenty Twenty-one
- If the issue is gone, activate one by one to see with which one there is an interaction issue

Could you tell me the results of this investigation? Also, can you enable the debug mode? Please add the following code in your wp-config.php file:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
  
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
  
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
  
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check the following links to read more about debugging with WordPress.
- https://codex.wordpress.org/Debugging_in_WordPress
- https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

After adding the code above, try to reproduce the issue again and check if you'll find a debug.log file inside the wp-content folder. If you locate it there, please send us the last lines here in the ticket.

We're looking forward to your reply. Thanks!

Regards,
Mateus.

May 16, 2022 at 12:30 pm #11229499

Tim

Can you please check for me the solutions u said didnt work. Its just when i change something on a product page that has wpml it changes everyhing.

May 16, 2022 at 12:31 pm #11229501

Tim

maybe u can login?

May 16, 2022 at 4:43 pm #11231701

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thanks for your reply.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of site files and database before providing us access.
- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this: hidden link

Please, let me know if you need any additional details. Have a nice day.

May 17, 2022 at 8:55 pm #11241809

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thank you for providing the website credentials.

We have just checked the products, but we weren't able to reproduce the problem. By changing the images and the titles, the products (original and translations) remained in stock.

Am I missing some fundamental steps in order to replicate the issue? Please keep us posted about this.

Thank you,
Mateus.

May 17, 2022 at 8:56 pm #11241819

Tim

Hi Mateus,

How did you change the image?

May 17, 2022 at 8:57 pm #11241825

Tim

i changed it now and the site is again broken

May 18, 2022 at 2:24 pm #11248079

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for your reply.

I have changed the image through the Edit screen of the product: hidden link

We also tried to change the titles, through the Edit and Quick Edit modes, but with no luck so far. Could you please tell us the exact step-by-step in order to see this issue?

Please let us know. Thanks!

Best,
Mateus.

May 19, 2022 at 11:27 am #11256235

Tim

hi,

here a short video hidden link

May 19, 2022 at 6:37 pm #11260271

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thank you for sharing the video.

Very strange, we have tested these same steps many times, and so far the issue didn't trigger. We tried to access the website in order to check again, but unfortunately we're receiving this message when trying to login: hidden link

Could you please review it? I'll mark your next reply as private again, in case you want to enter new credentials. Thanks!

Best,
Mateus.

May 20, 2022 at 7:53 pm #11268937

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thanks for providing the website credentials, but unfortunately, we're still receiving this message: hidden link, since the login details are the same as before.

Could you please review it once more? Regardless, we have another option. In order for us to take a closer look at this issue, I'd like your help creating a package of your website and sending it to us.

Please use the plugin Duplicator(hidden link) to create a full copy of your website so we can take a look at it and see what's causing the issue with the large table.

Please check our tutorial on how to create a Duplicator package here: https://wpml.org/faq/provide-supporters-copy-site/

If you come across problems while creating it, please feel free to ignore(exclude from the backup) both uploads and cache folders.

I'm enabling the proper field for your to share this copy, you'll see it on your next response.

Alternatively, you may use any file sharing service that you prefer and share the link in the ticket(your next response is being marked as private, only you and I have access to it).

Thank you, please let me know.

May 23, 2022 at 8:35 am #11277063

Tim

Hi,

Now you can login. Can you please make a video how you change the image of hidden link (the dutch product) without breaking the site like us?

May 23, 2022 at 6:26 pm #11283689

Mateus Getulio
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hey there,

Thank you for correcting the credentials.

The video is not necessary, we were able to reproduce the issue by changing the product image on the native WordPress edit screen.

The problem now is that after we recreated the product, in order to make it in stock again, the issue couldn't be replicated. Please check it: hidden link

Are you following any specific steps in order to create this product that we might have missed? Please let us know the exact step-by-step in order to replicate the problem and we'll continue debugging it. Thanks!

Regards,
Mateus.

May 23, 2022 at 9:23 pm #11284331

Tim

Hi,

I did send you a video on how i changed the image and getting a "not in stock" Can you please make a video so i can see how u change? This is taking way too long now