Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 4 voices.

Last updated by Andrey 7 years, 1 month ago.

Assigned support staff: Andrey.

Author Posts
October 1, 2013 at 5:02 am #270928

Christopher

Hello

Is there any possibility to change language urls???

Example:
swedish has /sv/, i want to changeit to /se/
danish has /da/, i want to change it to /dk/
etc....

October 1, 2013 at 8:51 am #271039

Anonymous

Hello Christopher,

Once entered, the language code (as you write /sv/, /se/, /da/, /dk/) cannot be changed.

So please make sure about the code when you add a new language.

To make custom code that is different from WPML's default settings, please follow steps:
+ In the admin panel: Go to menu WPML ==> Languages ==> Section "Site Languages"
+ Click "Edit Languages", you will see the setting table of all active languages.
+ Click "Add Language" to make new language with your settings. Please note: fill all the empty field, including column "Translation (new)".
+ Click "Save" to finish.

Thank you.

October 2, 2013 at 5:53 pm #271860

Christopher

Unfortunately, every time i try this operation, there is error: Adding language failed.

For Danish language with Code /dk/ a fill the following informations:

Language name: Danish
Code: dk
Translation (Danish): Dansk
Translation (English): Danish
Translation (French): Danois
Translation (German): Dänisch
Translation (Italian): Danese
Translation (Spanish): Danés
Translation (Polish): Duński
Flag: da.png (Use flag from WPML)
Default locale: da_DK or dk_DK (tried both)
Encode URLs: No
Language tag: da-DK or dk-DK (tried both)

October 5, 2013 at 1:54 pm #273134

Christopher

When i could get answer to my problem???

February 17, 2014 at 9:59 am #341219

Kristofer

We had the same problem. Try, instead of using Danish as Language name, using a name that isn't already taken. For example Language name: My Danish. Worked for us.

June 18, 2014 at 7:51 am #420928

Andrey
Supporter

Timezone: Europe/Kiev (GMT+02:00)

Dear Christopher ,

Are you still facing this problem ? Please make sure to use the latest versions of WPML plugin and try to add again a custom language in WPML >> Languages > Edit language.

Here you can compare your versions with the latest :
http://wpml.org/my-account/downloads/
_

With Regards

Andrey

The topic ‘[Closed] Changing language code URL’ is closed to new replies.