This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by leeC-2 1 year ago.

Assigned support staff: Bigul.

Author Posts
September 20, 2018 at 11:22 am

leeC-2

I am trying to: change the language flags to bigger round ones

I followed the existing support tickets but nothing seems to work.

1. I go to edit language
2. I upload my flag
3. I hit save
4. I get a blank page.

When I then go back to languages, nothing has changed.

I tried uploading the files to the wp-content/ plugins/sitepress-multilingual-cms/res/flag folder, but nothing happened.
I cleared my cache, no change
I also added the flag to /wp-content/uploads/flags but again no luck.
please help 🙂

September 21, 2018 at 12:59 pm #2755236

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Please let me know the following for tracking the issue.

a) Please share with me the Flag Image you are trying to upload

b) Please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

Please note, I am not able to login to your FTP becuase of the following error. Please check.


Status: Connection established, waiting for welcome message...
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 1 of 50 allowed.
Response: 220-Local time is now 15:01. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER **********.com
Response: 331 User **********.com OK. Password required
Command: PASS ************
Response: 530 Login authentication failed
Error: Critical error: Could not connect to server

--
Thanks!

Bigul

September 27, 2018 at 9:53 am
September 27, 2018 at 3:55 pm #2771123

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the details. I can reproduce the issue error on your site. But it works fine in my local copy when I tried with the same images. So it looks like the PHP is missing php_fileinfo module on your host, because of the following error.

PHP Fatal error: Call to undefined function mime_content_type() in

Please check with your hosting php_fileinfo module is enabled or not.

As a workaround, you can manually replace files in plugins/sitepress-multilingual-cms/res/flags folder.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

September 27, 2018 at 5:39 pm #2771412

leeC-2

Hi Bigul,

excellent, I replace the image in the res/flags folder as suggested and the round image shows now but it is till very small, how do I get it to be the correct size?

September 28, 2018 at 9:46 am #2773159

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. The correct size for the image flag files will be 18px*12px. Please check the attached image for more details.

--
Thanks!

Bigul

September 28, 2018 at 2:46 pm #2774263

leeC-2

I understand that but the client wants the flags to be bigger, how do I change the dimensions of the flag?

September 28, 2018 at 4:34 pm #2774432

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. It will be a custom requirement. It can be achieved by using custom CSS code in the child theme. Please check the sample code in following ticket.

https://wpml.org/forums/topic/change-flag-size-of-language-switcher-in-horizontal-menu/#post-1409790

--
Thanks!

Bigul

October 3, 2018 at 7:33 pm #2785583

leeC-2

My issue is resolved now. Thank you!