This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by stefanusP 4 months, 3 weeks ago.

Assigned support staff: Bruno.

Author Posts
May 27, 2019 at 2:11 pm

stefanusP

I am trying to: Change language to Dutch/Nederlands

Link to a page where the issue can be seen: hidden link

I expected to see: hidden link

Instead, I got: hidden link
Is there a way to manually update this? If so, I appreciate to learn this. Thanks!

May 27, 2019 at 9:11 pm #3900945

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. I would be very happy to help you but I didn't fully understand what is the issue.

Do you want to change the post slug? Or do you want to edit the page language?

Can you please elaborate a little more so I can better understand? Sometimes screenshots illustrating what you mean may go a long way to clarify what words fail to transmit so if you like make use of "upload an image" below the comment area.

Thank you.

May 28, 2019 at 6:04 am #3902943

stefanusP

Hi Bruno,

hidden link is default in English. When using the language selector, switching to Dutch, it goes to hidden link. It shall not switch from ../options to ../quote.
I will add screenshots when possible, but in this case I don't believe it's possible. If still unclear, can I add a video?
Thanks for your efforts on this!
Wr, Stefan
Aqqii

May 29, 2019 at 3:20 am #3911525

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

I'm not sure why the page displayed is incorrect. Have you tried disabling all non-WPML plugins for testing?

Unfortunately, I noticed that you created an account for me with the role "subscriber" so that I can not look in the backend.

Please, could you change the role of the user to "Administrator" so I can check?

Thank you.

May 29, 2019 at 12:20 pm #3915309

stefanusP

Hello Bruno,

sorry, I now updated the user-id, so please log in again.
I de-activated all but Elementor, WooCommerce and only some of WPML. The problem occurs 'only' when both 'WPML String Translation' and 'WPML Translation Management' (and thereby 'WooCommerce Multilingual' is effective) are activated.
As soon as one of these two is de-activated, the problem disappears (when changing the language to Dutch, it goes to hidden link)
Thanks for your support!
Wr, Stefan

May 29, 2019 at 11:51 pm #3919083

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

It seems to me that the "Options" page in Dutch is using the "quote" slug. I'll attach an image for you to see.

I just accessed the Dutch language and clicked on the "Quick Edit" link, just below the "Opties" page.

At the moment, if I try to access /nl/options/, the page is redirected to the default language, /options/.

In this case, you would only need to edit this slug so that the content was pointed to the desired URL. By following these steps, is the page still not displayed as desired?

Thank you.

May 30, 2019 at 8:02 am #3921111

stefanusP

Hi Bruno, resolved, thanks!
PS: Issue also related to understanding 'page per language', see other open ticket. I hope you can clarify it there.
Wr, Stefan
hidden link

May 30, 2019 at 8:02 am #3921113

stefanusP

My issue is resolved now. Thank you!