This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Carlos Rojas 2 months, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 5, 2019 at 9:26 am #4149589

christinaR-3

I am trying to: Changing the order of the gallery images in Elementor

Link to a page where the issue can be seen: hidden link

Instead, I got: I can't change the order of the pictures in the gallery. In the editor it changes but in the preview the order remains the same.
I contacted Elementor support and this is the answer I got from them:

"I'm afraid the changing order of the images issue is due to the "WPML Media" third-party plugin If I deactivate this third-party plugin I could change the order of the images from the image gallery widget."

Also, when in preview or after I publish the post, clicking the gallery images results in an empty display (see image)

July 5, 2019 at 10:44 am #4150415

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- Please describe step by step how to reproduce the issue so I can reproduce it on the site.

2.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Kind regards,
Carlos

July 15, 2019 at 1:37 pm #4211589

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for the information provided.

Before we continue I need to ask you to update all outdated plugins and themes to their latest version. Outdated functionalities can cause conflicts in the code.

Also, please flush all cache memory after the updates.

Could you tell me if the issue persists after the updates?
Regards,
Carlos

August 10, 2019 at 12:11 pm #4375283

christinaR-3

Hi,
Sorry for not replying for a long time. I was on vacation 🙂
I updated everything and in the preview mode, the pictures are switched. The only place I don't see the change is in the Elementor editor itself. I probably can live with that but would be great if this could be fixed as well.
Thanks

August 12, 2019 at 6:27 am #4378509

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

In this case I kindly recommend you to create a featured request in this link: https://wpml.org/suggest-a-new-feature-for-wpml/
This will go directly to our development team.

Best regards,
Carlos