This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by Diego Pereira 1 year, 1 month ago.

Assigned support staff: Diego Pereira.

Author Posts
August 15, 2018 at 10:17 am

Adam Kischinovsky

Hi,

I have a Website in Swedish and Danish.

The primary language is Swedish, When I change anything on any of the pages, it can be some text or a slider image or anything.
The whole page is replaced by the danish text.

Can you please help me solve this issue.

Thank you

August 15, 2018 at 1:20 pm #2646503

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Adam, welcome to the WPML support Forum!

Does this happen on a specific page or on all pages? Could you send us the link on the page?

If it happens on only one page, make sure it is not a duplicate. If so, you should enable the "Translate independently" option.

All the best,
Diego

August 15, 2018 at 1:34 pm #2646554

Adam Kischinovsky

Hi,

Thank you for the reply.

Unfortunately it happens on all the pages. 🙁
I don't think it is duplicated pages, I wouldn't know where to check that.

Looking forward to hearing from you again.

Thank you

August 15, 2018 at 5:01 pm #2647159

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

In thsi case I will need to do some tests on your website. Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” or "All-in-one WP Migration" on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site.

Please let me know if this is ok for you.

Regards,
Diego

August 16, 2018 at 2:57 am #2648302

Adam Kischinovsky

Hi,

Yes, sure. that is ok. Thank you

August 16, 2018 at 7:01 pm #2651063

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello Adam,

I duplicated the site on my local server and did some testing. I could not reproduce the issue:
- Edited the content of the "Booking" page (Swedish)
- Edited the "Danish" translation.
- Each page display his own content. Everything is working well.
- Edited the Swedish version again
- Each page continues to display his own content.

Are these the correct steps to reproduce the problem? Does it happen on a specific page? Could you give more details to reproduce the issue?

Regards,
Diego

August 30, 2018 at 2:12 pm #2690551

Adam Kischinovsky

Hi again, Sorry for my late reply.
I also tested it after I got your message again, and then it was working.
But now it happened to some other pages suddently.

I guess it happens sometimes and, sometimes it suddently just changes.
Recently a lot of the sub pages for reperationer, had suddently changed from swedish to danish. I don't have an explanation for this.

Can it have something to do with the pages having the same name on the danish and on the swedish language. so it shows the same name on the overview of all the pages?

I hope you can help

Thank you

August 31, 2018 at 12:57 pm #2693786

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

- Does your server have any type of cache?
- Are you using the manual editor or the Translation editor?
- Could you please send the links of the pages, so i can take a look?

Kind regards,
Diego

August 31, 2018 at 1:15 pm #2693827

Adam Kischinovsky

Hi,

1. It is running some Varnish Cache. They said I can disable it if I want? Should I do that?
2. I don't know what the difference is? I click the plus next to the page, and write the text in the other language and publish
3. But It is different random pages, I don't know what pages exactly. It has happened to the front page, and to the pages under "reperationer", and other pages.

I hope this can help you find the solution.

Every time it happens, I just go to revisions, and go back to a point in time when it was the correct language, so right now I think that all of them are the correct language.

Thank you

August 31, 2018 at 3:23 pm #2694414

Adam Kischinovsky

It just happened to this page: hidden link

I will change it back now, but just so you know, that this is one of the pages.

August 31, 2018 at 8:41 pm #2695037

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi there,

As this is a bit random, it might be caused by caching issues. Could you disable the Varnish Cache?

If the problem occurs again, please let me know.

Regards,
Diego

September 8, 2018 at 7:26 am #2716588

Adam Kischinovsky

It seems like it is working, but the client said that they will test everything on monday and tuesday. But thank you very much.

September 10, 2018 at 12:36 pm #2719906

Diego Pereira
Supporter

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thanks! Please let me know if it worked.

Kind regards,
Diego