This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The client is using the "Events Schedule WP Plugin" and after he translated the events with WPML, the translated events (that are delivered by the plugin, after taking the content from WPML) are shown only after the client refreshes the page

Solution: The client said he solved it this way: "I started experimenting with the ascendant's predictions and managed to solve the problem. In Classes->Settings->Advanced->I disabled and all started working correctly."

This topic contains 7 replies, has 2 voices.

Last updated by gatisP-2 4 months, 3 weeks ago.

Assigned support staff: Mihai Apetrei.

Author Posts
May 30, 2019 at 9:28 am #3921703

gatisP-2

I am trying to: I builded shedule for each language.

Link to a page where the issue can be seen:
hidden link

I expected to see:
Changing the language of the page will also indicate the language in the event list.

Instead, I got:
Language is changing when I'm refreshing the page! it doesn't change right away.

May 30, 2019 at 4:08 pm #3924613

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I was able to visit the link that you shared with me and to see the issue.

1. Can you please let me know how you are serving that content? I mean what I would need to know is what exactly is serving that content on the page: a plugin (if yes, what plugin) or the theme that you are using?

2. Can you please try this:

- disable all plugins except WPML and its add-ons (if what is serving the content is a plugin that you use, leave just WPML and that plugin enabled)
- check if the issue is happening again
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know what you will be able to find.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

May 31, 2019 at 6:02 am #3927929

gatisP-2

Hi Mihai!

Thank you for your reply!

I checked the suggestions, but it didn't solve the issue.

This content serving Events Schedule WP Plugin.
hidden link

Thank you and look forward to your further support.

Best regards,
Gatis

May 31, 2019 at 1:28 pm #3930899

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the feedback.

I have created a clean sandbox testing environment for you here (one-click-login):
hidden link

I would need you to please set up WPML as you have it on your site (it is already installed), then install the events plugin that you are using and try to replicate the issue without using any other plugins and by using the current default WordPress theme.

If the issue will happen even on our servers, on a clean install setup, then that's when I can forward this issue to our Compatibility department.

Please let me know how that goes.

I will be waiting for your response.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

May 31, 2019 at 3:35 pm #3931763

gatisP-2

Hi

Thank you for creating a test platform! I installed this plugin and set up resources.
Here everything works right. Switches languages without reloading the page.

hidden link

Here everything loads faster and without delay.
The resources of this plugin are slow and delayed on my website.

May 31, 2019 at 3:53 pm #3931879

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the confirmation.

Then can you please take a look over your site and try this:

1. Make sure that you don't have any custom code like Javascript code that might cause issues. If you have any, try to copy it into another place on your local computer and try to remove it from the site and see if the issue is still happening.

2. Check if all the plugins and the theme you are using is using the lastest version available (check that you don't have any updates available that you did not do). If you have updates available, first create a full backup of the site and then see if the issue is still happening after you update everything to the latest version.

3. Increase the MaxInputVars to 50000 - currently, you have them set at 3000.

For this, please try to set this variables in your php.ini:

max_input_vars = 50000;
suhosin.post.max_vars = 50000;
suhosin.request.max_vars = 50000;

You may need to contact your hosting provider to set them.

Please make sure you have updated the values successfully, You can verify them from WPML >> Support page.

Please let me know how that goes and if following any of these steps solves your issue or bring any change.

I will be waiting for your response.

Just a note that my shift ends now but I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai Apetrei

May 31, 2019 at 5:00 pm #3932299

gatisP-2

Thanks Mihai for support!

I changed everything but nothing.

I started experimenting with the ascendant's predictions and managed to solve the problem. In Classes->Settings->Advanced I disabling <Enable Lazy Load> and all started working correctly.

Thanks for your time!
Gatis

May 31, 2019 at 5:01 pm #3932327

gatisP-2

My issue is resolved now. Thank you!