This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The & character is showing up as ET in all languages.

Solution: This issue was not related to WPML, it was coming from the font. The "&" in the font come out like "ET". Changing the font resolved the issue.

This topic contains 4 replies, has 2 voices.

Last updated by Pascal 1 year ago.

Assigned support staff: Lauren.

Author Posts
October 11, 2018 at 7:58 pm #2809655

Pascal

I want to use the character "&" instead of "and" in English and "et" in French.

Even if I use "&" or & in the text, it displays "et" in both languages on the site. In French, it doesn't matter but doesn't work in English

hidden link

Scroll down to the following text:

Funny et Engaging Family Entertainment

The text in the dashboard is:

Funny & Engaging Family Entertainment

Thanks

October 12, 2018 at 7:19 pm #2812955

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

First, please try increasing the WP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/

You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it above the line /* That's all, stop editing! Happy blogging. */

Next, check your database tables and fields to make sure that they are all using the same collation.

If all of that looks okay, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentySeventeen. With these settings, does the "&" show correctly?

October 16, 2018 at 4:41 pm #2821840

Pascal

I found the problem, so I will mark the ticket as resolved.

I just want to tell you that the problem is not from wpml or conflict with other plugins.

It is coming from the font. The "&" in the font come out like "ET"

hidden link

Thanks,

October 16, 2018 at 5:42 pm #2822008

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks so much for letting me know that you resolved it, and the cause. This will be helpful if any of our other clients run into something similar.

October 16, 2018 at 5:44 pm #2822009

Pascal

My issue is resolved now. Thank you!