This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 23 replies, has 3 voices.

Last updated by Bigul 1 month, 1 week ago.

Assigned support staff: Bigul.

Author Posts
August 21, 2019 at 8:55 am

great-i-amL

I am trying to: Since last update all of the strings I had translated (shipping methods, VAT, Payment Descriptions) lost their translation.
Now on Checkot all of that is in English and even though the strings are translated they do not apply on front end.
The page slug also lost its translation, it was something like /finalizar/ and now it assumed the english slug /checkout/.

Link to a page where the issue can be seen: hidden link

I expected to see: All of them should be translated.

August 21, 2019 at 10:41 am
August 21, 2019 at 10:44 am #4430439

great-i-amL

Where can I upload the duplicator link?

August 21, 2019 at 10:47 am #4430449

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

You can create the duplicator and let us know I will download it from the site itself.

Thanks

August 21, 2019 at 11:27 am #4430767

great-i-amL

Can you do it? Been trying but it has tons of different options. If you could do it it would be perfect. (you can instal plugins if you want to since its a staging website).

August 21, 2019 at 1:54 pm #4432023

great-i-amL

Duplicator is done. Please check the package there.

August 22, 2019 at 4:32 am #4436259

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

On the localhost replicate the issue is not existing, so it looks like an issue on the site itself.

Do you have any cache service enabled? If so can you disable it and check if this helps?

Also, can you disable all WPML plugins once and reactivate it?

Look forward to your reply.

Thanks

August 22, 2019 at 8:50 am #4437569

great-i-amL

That's really weird. I've disabled litespeed cache and autoptimize, disabled all wpml plugins and enabled again. Issue still remains.

August 22, 2019 at 9:23 am #4437879

great-i-amL

I've deactivated each plugin, deleted it. Instaled from scratch, same issue.

August 22, 2019 at 10:37 am #4438377

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Can you check if there is anything in server error.log and see if there are any issues logged there?

Look forward to your reply.

Thanks

August 22, 2019 at 11:52 am #4438919

great-i-amL

No errors on error log

August 22, 2019 at 2:04 pm #4440059

great-i-amL

For your info: I've reverted to the latest version I had on all 4 wpml plugins and it came back to normal. This has to be related with something with the gettext change on the latest update.

August 23, 2019 at 10:13 am
August 23, 2019 at 1:42 pm #4447797

great-i-amL

New Migration is Done.

I migrated the staging website, there you can find the latest version of the plugins (translations not working on checkout). If you try previous versions of the plugin you'll see it works again.

August 26, 2019 at 3:06 pm #4460057

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

I am Bigul from WPML support team. Shekhar is on vacation now. So I am taking care of this ticket. Hope it will be okay for you.

Thank you for the migration steps. But the site frontend is not loading for me. The result is also the same with default theme. So I will check about this our team and get back to you soon. Please wait.

--
Thanks!

Bigul

The topic ‘[Closed] Checkout Expressions Not translated after latest update’ is closed to new replies.